Graphics Pausing but Audio Not

0 favourites
  • 4 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • So I'm working on a rhythm game and it seems to be going alright but I found out something that ruins it all and thats when you hold click on the X button of the window, it freezes the entire game except for the audio which completely causes everything to be out of sync. Is there a way to disable the normal window buttons when the game is exported as a standalone executable so that there is no X button to click? Or is there a way to make the audio also stop while holding the mouse click down on the X?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Audio >> Properties >> Play in background >> No

    is that it???

  • Audio >> Properties >> Play in background >> No

    is that it???

    I checked that and it's already turned off. It stops playing when minimized but while holding the X button down, it continues while the rest of the game freezes

  • I played around here, and the Browser plugin kinda seems to solve the problem.

    you can make an fullscreen request on an 'On Touch' block (unfortunately or not, browsers block any fullscreen request that's not associated to an user input) so then you set the audio property Timescale Audio to On.

    So then you make:


    Browser | Is fullscreen

    >> System | Set Time Scale to 1

    //any more pausing effects you may want (I used opacity and a pausing icon)

    System | Else

    >> System | Set Time Scale to 0

    //remove pause effects

    You can only hold X when you aren't in fullscreen mode.

    And since the game (and audio) pause when aren't in fullscreen, you can't pause something that's already paused.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)