How to fix MobileAdvert error: unsupported URL?

  • Hi,

    I trying to using Mobile Advert into my project, when export into iOS I got the following error

    ERROR: Rejection from 'advert' handler 'Configure': unsupported URL

    [C3 advert] Event (configuration failed Error (unsupported URL) Type ()

    Nepeo and suggest that this error is because of my privacy url is incorrect.

    Here is my url: zobukgaming.com/privacypolicy.html

    What I have tried so far:

    zobukgaming.com/privacypolicy.html

    http://zobukgaming.com/privacypolicy.html

    https://www.zobukgaming.com/privacypolicy.html

    http://www.zobukgaming.com/privacypolicy.html

    zobukgaming.com/privacypolicy.html

    zobukgaming.com/privacypolicy.html

    www.zobukgaming.com/privacypolicy.html

    www.zobukgaming.com/privacypolicy.html

    None of them work.

    Any suggestion?

    P/S:

    - I'm change it in exported xcode project via data.json file. Do I need to change it from Construct before export? If so, which url pattern work?

    - It's strange, I turn off TestMode in, export again and build, still the same error, with error on create Interstitial also

    [C3 advert] Event (interstitial created Error () Type () Amount (0))

    but when I check my Admob account, it show request = 4 and match rate = 100% (still no ads show).

    Or did I do something wrong?

  • The below log message isn't an error.

    [C3 advert] Event (interstitial created Error () Type () Amount (0))

    The log has the format Event ({MSG} Error ({ERR}) Type ({REWARD_TYPE}) Amount ({REWARD_AMOUNT})), note how the error part is empty in your message. It's just saying that it succeeded to create the interstitial.

    I can't really offer much assistance without a project to look at.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can't really offer much assistance without a project to look at.

    Would you please help, here is the sample

    drive.google.com/file/d/1EcCRH3BuDXcsWCaGDW-0pqEUDgh0V7p_/view

    I did tried in testmode(On/Off) with my created app unit id and also test unit id (from admob site)

    - It show unsupported URL.

    - When I using my app unit id, the log is

    ERROR: Rejection from 'advert' handler 'CreateInterstitialAdvert': Request Error: No ad to show.

    -When I using test unit id, the log is

    [C3 advert] Event (interstitial created Error () Type () Amount (0))

    1. How should I fix the unsupported URL?

    2. Tell me if I doing anything wrong inside my sample?

    Note: Not only the error log, I did not see the ad (test mode or not) after many tries

    Thank you so much

  • The error isn't particularly descriptive, it's coming from the Admob SDK. I backtracked it and it's not actually related to the privacy URL, although it can generate the same error message. You have a space at the start of your publisher ID, which it's using to build a URL. Remove the space and it works fine.

  • I've made some changes for the next release so that leading/trailing whitespace is removed on any Admob ID and the privacy policy. Should stop people getting caught out by this in the future. Thanks for bringing the issue to my attention.

  • Thank you so much :D you saved my life!

    Never realize that space

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)