How do I export my game, as of November 5th? "MobileAdvert" plugin doesn't seem to be working?

  • Hello all, as of November 5th (today), my export stopped working. I exported the app, two days, and it worked fine (but for some reason, I deleted the file). So, I tried again to export it, but when I tried to run it on my Android (the same one I was using just two days ago), it wasn't working -- the bar loads then stalls, and closes the app before it can even open, at 85%.

    I believe it's an update issue. I changed nothing on my app. It opened before, but it won't open now.

    ... But why?

    Can someone please help me out?

    (BTW, the phone I'm using is an Android 5.0.1, with a Kernal version of 3.4.0)

  • Is the "MobileAdvert" plugin not working again? If so, which plugin should I use in it's place? Which is still working, as of today?

  • The is definitely with the MobileAdvert plugin. I just remove the plugin completely, and the app began to load on my phone properly again.

    Nepeo What's the problem with MobileAdvert, and how do I go about fixing it? I read your post construct.net/en/forum/construct-3/how-do-i-8/breaking-change-mobile-advert-145087 but I'm still confused about how to actually fix it.

    Just like you said, the app keeps crashing by the SDK on startup (as I said before, the loading stops at around 85%)!

    I put the "" around my Admob App ID, but it still didn't work.

  • Now, after updated Construct to Beta r174, it's gone from bad to worse... Now my app doesn't even load. It's just displaying a complete BLACK SCREEN, without even loading... This is not good.

    How do I fix this MobileAdvert problem? Everything was working a few days -- I changed absolutely nothing since!

    Please, (Someone... Anyone) I need some help.

  • See also comments in this post. App ID should be entered without quotes.

    If it doesn't fix the issue, then it's probably a different problem and you need to log a new bug report.

  • dop2000 I know. I took out the quotes, but the problem is still persisting. I know it's a MobileAdvert problem though, because when I remove the plugin completely, it works again. There's nothing wrong with the app... If I send it to you, can you tell me what to fix?

    Also, I am using the right AdMob App ID as well (for example, it looks like this): ca-app-pub-3940256099942544~3347511713

  • If it was working 2 days ago and now doesn't, then there is probably nothing wrong with the project, and it's likely a bug with the build service.

    I suggest you try to reproduce the problem in a small project and log a new bug report.

  • It's important to differentiate between what you mean by "crash". People tend to use it to cover a lot of things, including myself sometimes. The specific reaction you get from the SDK when the App ID is wrong is that the application will close immediately. Anything else and it's not caused by that change. So seeing a black screen, or being stuck at 85% isn't caused by that specific change.

    As dop2000 says the best course is to find a minimal example that causes the issue and post it to the bug tracker. There's no known issue with the Mobile Advert plugin on Android at the moment, so I will be keen to follow this up if you can create a nice solid reproduction for us.

  • Nepeo and dop2000 ... [Sorry, I went to https://github.com/Scirra/Construct-3-bugs, but I have have no clue how to post anything.] Pretty please:).... Can I just send you my cpax file? If so, where can I send it? If not, can you please tell me how to post on that specific GitHub page, or whatever?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I do just click on "Create new file" on that page (https://github.com/Scirra/Construct-3-bugs), and then go from there?

  • Nepeo and dop2000 I FIXED IT!... The problem was that I had too many songs in my app (three two minute songs -- I got rid of two of them, and my app began to load as usual).

    All is well now; thank you for the help guys!

  • On gitHub, there is a tab "Issues".

    Click it, you can browse the list of existing bugs there.

    You can also click "New issue" to post a new report.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)