How do I export my game on Android so it is compatible with Android WebView Factory default version?

  • Hi there, I need to deploy an apk built from a C3 project on Cordova CLI version 8.1.2. It works fine on most devices, but I need it to run on an Alcatel Pixi 8079 tablet. It asks for an update of the Android webView in order to work (missing feature: webAssemply). However, when trying to update webView in PlayStore, it can´t install it anymore (it installed fine previous versions but not the latest ones). So I need to find a way to make C3 project to work on the factory´s default version of webView (v43). Can anyone help me?

    Tagged:

  • The Construct 3 runtime requires an up-to-date webview. It only needs to have had an update in the past couple of years to work. v43 is around 4 years old which is too old to be compatible. The problem you need to fix is updating the webview. It should work for any Android 5.0+ device. Googling the model gave me this which appears to be compatible since it has Android 5. Why can't you update it? What happens? Is there some kind of error message?

  • When trying to update from google play in the alcatel pixi 8079, it downloads the update, keeps installing it for a while, and finnaly it says it couldn't be updated but without throwing an error. Tablet has android 5 and armv7 architecture. It's weird cause it used to work fine until webView's version 71. Thanks for helping me.

  • What's the exact text of any error messages that appear?

    Does the device have enough storage space to install updates?

    Doesn't the device at least have the webview v71 then? That one is new enough to work.

  • It has enough space, it´s almost empty and I can install other apps without any problem. Other people also tried in other tablets same brand and version and same problem happens.

    The project is being developed for a public education institution. It will be deployed on thousands of those tablets, so manually updating to webview 71 with the webview´s apk is not an option for them. Here´s the message i am getting after it gets stuck for like 15 minutes trying to install. It is in spanish but translation is "WebView for Android System couldn´t be downloaded, try again and if it keeps not working, check for common ways to solve the issue". I´ve tried several times, also sent a comment, sufred the net, but couldn´t find a way. It is a very big project and I´ve bet on C3 and not C2 for it´s performance. There may be a way to disable webAssembly or to force webview update from some cordova plugin?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That's weird, I've not heard of that happening before... I guess you'd need to contact Google to get to the bottom of what's going on there.

    You can switch the project back to the C2 runtime, which works with older browsers. However it has fewer features and reduced performance. You might need to remove some things from your project to switch back. See the manual entry on the C3 runtime for more details.

  • Thanks Ashley, I really hope google replies to this, as we spent a lot of time migrating it from c2 runtime to c3, so you can imagine the pain it is to get back to c2! And the lack of performance!

    If you know a good channel to communicate this to google and make them to read it please let me know.

    Thank you!

  • I'm not sure it's the right place, but filing an issue at crbug.com might at least be a good place to start. It's the bug tracker for Chrome, but it also covers the WebView. If you explain the problem with the WebView app not being able to update, they might be able to do something about it.

    I think the weirdest thing is if it worked with v71, then from what you've said it sounds like failed updates beyond that have actually reverted it to the factory v43. A failed update should have at least left it on v71!

  • I Will definetly do that, thanks Ashley!

  • Oh, and let me know the issue number here. We've had various reports of similar sounding issues over the past few months and it's always been a mystery what's going on, so it will be interesting to see if Google can find an issue.

  • Done! issue # is 970247

    Thanks!

  • Hi Ashley, just to let you know, yesterday google released a new beta version of the WebView (75.0.3770.75). I tried it inmediately in the Alcatel 8079 and it worked fine! even tough it is not yet available on Play Store, it is a good sign as I imagine they will release it soon.

    I really want to thank you for your great support and congratulate you for all the awesome improvements you are making to C3 day by day.

  • That's good to hear, but if the problem is not actually solved, it's hard to be confident it won't come back in future again...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)