Construct 3 HTML Randomly Fails to Load (Incognito Mode Issues)

0 favourites
  • 8 posts
From the Asset Store
Casino? money? who knows? but the target is the same!
  • I had a quick question with a game that I am trying to release on and I'm wondering if anyone has any advice. I'm running into problems when I try to export the game from Construct 3 and play it in It works perfectly when playing it through the Construct 3 play tester.

    I have downloaded the game for HTML and it is around 50 MB. (on Chrome) displays the entire loader and loads to completion, however, the screen then goes black and the game won't start. Using the inspect element tool, I can see lots of red error messages appear in the console section. "Uncaught (in promise) TypeError: Failed to fetch" is the most common error; it occurs hundreds of times each time I try and fail to load the game. "Error loading resource: TypeError: Failed to fetch" is also very common. The number of errors seems to fluctuate each failure, for example, I had 1433 errors last time, but I've had closer to 600 as well.


    -The game can sometimes load, start, and play properly if I repeatedly reload the page until no red errors occur.

    -The game also works all of the time in an Incognito Tab. In this instance, it provides the message "Failed to register service worker". No red errors occur. I also can't save as I am using Incognito.

    -On Safari the game will work all the time from what I can tell, however, memory restrictions prevent it from being a viable option as Safari auto reloads pages that take lots of memory.

    -I have tried exporting the game to gamejolt which also doesn't work and many errors occur in the console tab of the inspect element tool.

    I'm not very knowledgeable on this subject and I'm wondering if there are any fixes for this problem? I have multiple demos for the game available on as well, none of which have any errors despite the same export method being used. Is this a problem with or Construct? The game was originally built on Construct 2 but has always ran using the C3 runtime. Should this make a difference? Most of the demos I've released use the C3 runtime as well.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It sounds like network requests are failing. That type of thing is either a problem with your Internet connection or the server.

  • It is very similar to this problem:

    The error codes are very similar. Is there any way to fix this in Construct 3 or should I contact more? Gamejolt failed too.

  • I would assume that issue is completely unrelated and that this is not related to Construct itself. You should start by checking your Internet connection, and then if you're sure that's working, contact the host for support.

  • What do you think the fact that it works perfectly in Incognito means? I feel like that is important to understanding the issue but I'm not well versed in coding stuff.

  • I don't know, it's no use asking me questions about someone else's hosting service. You should contact them first.

  • Do you have add ons such as ad block or other in the browser that is not working? If it is working correctly in other browsers, and in incognito mode it could be an addon interfering. A lot of addons are disabled by default in incognito mode.

  • Thanks for all of the advice! It seems the problem is only on my end, as everyone else who has tried the game has not had issues. I assume this means it is with my network connection.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)