Browser plugin not working after export to apk

0 favourites
  • 6 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • I am using the Browser action (Open URL in a new window) in my app. Works fine in preview mode. When I export to Cordova and create an apk, the Browser call is ignored once running on an Android device. I have created a simple test program that does nothing but make the call. Tried this with Construct 2 and 3. Works perfectly in preview mode in both versions. I have been trying various combinations of exporting to Cordova and then to the Intel XDK then using Construct 3 build to create a debug apk. Since Intel has depreciated their XDK features such as white listing are not supported in Intel App preview. You have to test it on an actual device. I have tried no less than 50 combinations that vary from using a debug apk to publishing an alpha version on play store.

    I have tried backtracking to kitkat with C2 and then importing into the C3 builder but I can't see where to edit the white listing tags. I have tried all available versions of Cordova with Crosswalk and without.

    These calls used to work on older versions. I suspect that newer security measures either in Cordova, Android or the browsers themselves are killing the action. I do have two year old apps on my phone that use this call just fine. What changed?

    I have tried using the wildcards "*" in the XDK build specs but they seem to have no effect. I have tested access, intent, and navigation.

    Here is a simple action.

    -> Browser: Go to "" in a new window ("Google Maps")

    Anyone who can suggest or can make the Browser function actually work on an Android phone would be a rock star to me. I have been testing this for a week.


  • Don't use XDK, it has been deprecated so it is not working anymore...

    Try using Phonegap instead.

    Export from C3 to Cordova. Possibly use Cordova CLI

    If there is still an issue, consider looking in the bug database if a similar issue exists, otherwise post your own report following the guideline.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Try to install the "inappbrowser" cordova plugin to your project.



  • Thanks for the prompt reply.

    AndreasR: The in app browser plugin is automatically included. I wonder if it might be the problem. I haven't figured out how to NOT have it included. Currently using the Browser plugin automatically includes it into your project when exported. Usually found in the plugin directory that is created.

    Kyatic: I have tried many iterations bypassing the Intel XDK. Both using C2 and C3. Bottom line, Browser simply is no longer working on Android devices once exported. Phonegap requires a paid subscription which I am reluctant to engage for something that may or may not work.

    Note that the only place to enter whitelist info is in the Intel XDK build setup. Using the C3 export build process does not allow any white list entry. I have attempted to edit the config.xml file generated but C3 build creates and uneditable version of config.xml.

    The browser action statement I listed above is the capx code needed to test. Pretty simple.

    Looks like I need to submit a bug report.


  • Like most projects I was looking to do both an Apple and Android version. I thought Android would be the easiest to start. Not the case.

    Did C3 export to Cordova iOS xCode and fired up my Apple development system. As usual, lost a day upgrading the operating system and installing xcode 9 but the result is that the simulators run the code perfectly. Great job, Scirra! Now need to figure out how to migrate from xcode to app store. It has been awhile and a lot has changed. Looking for a good tutorial.

    This leads me to believe the culprit is the plugins loaded. There have been so many version changes they are probably out of sync. Suspect I will have to set up the whole cordova environment that bypasses the XDK to work it thru. It would be nice if the C3 build worked.

  • mageekm Did you ever resolve this?

    I am having the same trouble with C2 and Cordova CLI.

    It used to work but doesnt any more.

    I can;t remember if there was a slight update needed on the config.xml file created but can't seem to find anything online to help

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)