How do I autoplay sound on NW.js build with remote main?

0 favourites
  • 1 posts
From the Asset Store
12 main music themes, 12 in-game loops and 24 win/lose stingers
  • Hello,

    For a client I'm using a NW.js build with external URL in order to have a fixed version of chrome and more control on the PC where the experience is "installed".

    Everything great except 2 issues. This is my current package.js configuration

    	{
    	"main": "http://www.risingpixel.com/others/previews/platano/",
    	"name": "TestPlatano",
    	"description": "",
    	"version": "1.0.0.0",
    	"window": {
    		"icon": null,
    		"title": "TestPlatano",
    		"width": 1920,
    		"height": 1080,
    		"position": "center",
    		"resizable": false,
    		"frame": false,
    		"kiosk": true,
    		"show": true
    	},
    	"user-agent": "Mozilla/5.0 (%osinfo) AppleWebKit/%webkit_ver (KHTML, like Gecko, Chrome, Safari) NWjs/%nwver",
    	"chromium-args": "--enable-node-worker --disable-plugins --disable-internal-flash --disable-popup-blocking --allow-file-access-from-files --ignore-gpu-blacklist"
    }
    

    1) How do I auto-enable sound? If I tap on the screen the sound can play, but in a vision of "autoplay video without any touch" how enable sound without first tap?

    2) How do I really disable cache? I tested with –disable-application-cache –media-cache-size=1 –disk-cache-size=1 — "%1" but no I see no effects... Only workaround I've found is a .bat file on startup which delete %APPDATA% folder of this application.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)