Android Cordova WebGL 2 issues r137+

  • So I have been using Construct r137 (beta), but something is breaking on my project after that, and built APKs are not working properly on some phones.

    Is there any way to rollback my project to the latest stable version? I am not using any of the new features introduced since then.

  • It sounds like a return of an old Android bug, it would be appreciated if you could file a new issue for us to investigate.

    To go to the current stable just visit https://editor.construct.net, it always points to the latest stable ( not beta ). You can choose a specific release on the releases page it will tell you to update, but you can ignore this.

    Projects saved with a newer version won't open in an older version, this is for compatibility safety. In most cases the project can be safely modified to open in an older version.

  • I am trying to figure out what the error is, unfortunately I don't have access to the phones at the moment, I'll check it out tomorrow and file an issue if there actually is one.

    In most cases the project can be safely modified to open in an older version.

    That is precisely what I need to know, what needs to be modified? Since I'm not using any of the new features, what can I do to convert it back to the latest stable?

  • So I have reverted the entire project to 135.2 (I'm using SVN), and tried to export with both 135.2 and 137, without any changes whatsoever.

    When exporting with 135.2, the project worked as expected. But on 137, I got black screens when changing layouts.

    No errors were seen in the console when debugging, so I could not identify what is wrong... Unless I share with you the whole project, there is not much else that I can do right now...

  • TheScythe I wouldn't exactly encourage editing the version, as you may corrupt your project ( so always keep a back up ).

    C3P files are basically zip files, with predefined internal layout. What you see with folder projects is that internal layout. I'm not sure which format your using, but the process is much the same.

    If your using a C3P then I would advise opening it ( not unzipping ) with some variety of archive tool like 7 zip, you can edit the files within the zip file without you needing to unzip it like this.

    You want to edit the project.c3proj file ( it's in the JSON format ), each addon will include it's own version number in the style "r137" which you will want to change. Additionally there is a project version in the format "13700". If you want to move to a point release then the values will look a little different, you should try looking at a project saved with the version you want to target if that's the case.

    I believe the issue is graphics driver problems when using webgl2 ( these generally don't produce any actual errors, just rendering problems like blank screens ). We have a device in the office that had the issues previously. If you are happy to share the project ( not an APK ) privately I can test it for you on that device and we can see about resolving it before the next stable release. You can contact me privately at iainasx@scirra.com

  • When exporting with 135.2, the project worked as expected. But on 137, I got black screens when changing layouts.

    Could you check r136? The WebGL 2 change was made after that release for r137, so this would help narrow it down to that.

  • I also had this exact issue with my apk made with 137.

    Went back to 136 and it worked as expected again.

    Android 8.0

  • To be able to diagnose this problem it's very important to have comprehensive information: the device model, device manufacturer, Android version, and the type of export (Cordova or web) are all essential. Without this we can only guess what to do about this.

  • Manufacturer: Huawei

    Model: Honor 9 lite

    Android: Android 8.0

    Export: Android studio

    When exporting with 137 only the background is shown. Touch inputs are still recognized (you can touch buttons and change layouts etc.) but only the background color is shown. 136 works like a charm on android. :)

  • boulerzzz - does the project use Mobile Advert (admob ads)?

  • I have tested on two devices:

    • Device 1

      Manufacturer: Alcatel

      Model: A5 LED

      Android: 6.0

    • Device 2

      Manufacturer: OnePlus

      Model: 5T

      Android: 9.0

    Export type: Android Cordova (tried Release and Debug).

    Chrome: Latest

    Webview: Latest

    Has Mobile Advert plugin.

    Exporting with 137 works on the second device, but not on the first. Exporting with 135.2 and 136 works on both.

    I have a small intro, where I show some logos. This part always works. After that, when the layout is changed, I get a black screen (background color), music and sounds, and the game responds to touches and further changes layouts.

  • yes.

    When I start the project I use the IAP plugin to check for some products and after that I load a banner ad. So I use the mobile advert plugin in my project AND use it to load a banner advert at the first layout.

  • Does it work OK if you remove Mobile Advert?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can't try until a bit later today. I'll update and let you know asap when I tried it!

  • Ashley

    Does it work OK if you remove Mobile Advert?

    For me, it didn't, apparently. I have removed some external plugins (GameAnalytics), Google Play Games, and Mobile Advert. Even without those three, I still hit a black screen.

    Also, Nepeo, I have sent a download link for my C3P project file in the e-mail address that you informed.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)