What's your favorite C3 bug you can't reproduce to report?

0 favourites
  • 11 posts
From the Asset Store
Match same tiles with each other as fast as you can and earn more score during a limited time!
  • Mine is where it randomly crashes saying something like "context stack reached 100 - is this right?" because it's hilarious that C3 is asking me if it messed up when I don't have access to the code at all.

    That or the preview buttons sometimes stop working for no apparent reason and I have to restart C3.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Trying to use C3 on an iPad Pro is basically a coin flip as to whether or not it will randomly crash - there’s never any particular reason, it just doesn’t like doing anything even marginally more intensive than scrolling an event sheet

  • When the internet goes down I just see a big C3 Icon when I try to use contruct. I know my license is supposed to work even when the internet is down.

    I can get the beta to work, so that is something.

  • Everything when trying to use timeline bar.

  • That or the preview buttons sometimes stop working for no apparent reason and I have to restart C3.

    Lol the Preview button stops working for me too. Mostly happens after I disconnect & re-connect my internet connection

  • Last time when I was making mobile game, advanced minification was not working (although simple minification was working). With advanced minification,the app used to get freezed at the starting itself.

    The funny part ,I was unable to reproduce it. And I am afraid that it may come back on next use

    Also, "Construct 3 works offline" never worked for me. Whenever I click on "New Project" in absence of internet connection,error message comes that unable to load

    And the fun in that:- if I open a project using "Files" button,the project opens and it even runs

    So to overcome the issue,I have a blank copy of a save file. I load it instead of making a new project

    Also, when I load image from files folder in Sprite, no idea why, sometimes randomly the images gets zoomed so much that it looks blurry. It happens 9:1

    Currently,to overcome the issue,I add "wait for previous action" after load image action. But maybe it may not solve the issue

    Moderator edit: Also you should use the "Edit" button in the forums instead of posting multiple posts in a row.

  • Last time when I was making mobile game, advanced minification was not working (although simple minification was working). With advanced minification,the app used to get freezed at the starting itself.

    Advanced Minification can be sometimes resource consuming especially for older computers. (I think my old computer used to get really slow during these processes a few years ago)

    Do you get any error message popup which says "Advanced minify failed, please check console" or something like that?

    Also, when I load image from files folder in Sprite, no idea why, sometimes randomly the images gets zoomed so much that it looks blurry. It happens 9:1

    Might happen because of your "Size" parameter.

  • > Last time when I was making mobile game, advanced minification was not working (although simple minification was working). With advanced minification,the app used to get freezed at the starting itself.

    Advanced Minification can be sometimes resource consuming especially for older computers.

    Do you get any error message popup which says "Advanced minify failed, please check console" or something like that?

    > Also, when I load image from files folder in Sprite, no idea why, sometimes randomly the images gets zoomed so much that it looks blurry. It happens 9:1

    Might happen because of your "Size" parameter.

    Completely wrong assumption. 1.) In advanced minification I used to get the APK at the end but after installing it and running it,it used to get freeze at the logo. Nothing to do with PC performance

    2.) Na,I already said,it was a random bug. I perfectly know those options. Rarely,like 1 in 20 times,it comes. And it is also visible on mobile too.

  • 1.) In advanced minification I used to get the APK at the end but after installing it and running it,it used to get freeze at the logo. Nothing to do with PC performance

    Aah I see. That means there is bug due to a third party plugin you are using (or due to custom Scripting). Often the third party plugins fail to provide support for advanced minification. You need to debug it using Developer Tools.

    Or maybe remove a suspected plugin and try minifying again to see if that works.

    (I thought your Construct 3 editor was freezing during Advanced minify when I read your previous comment)

    2.) Na,I already said,it was a random bug. I perfectly know those options. Rarely,like 1 in 20 times,it comes. And it is also visible on mobile too.

    Well, that's wierd.

  • The best was the greyed out screen that you came back to after running a preview. It happened only sometimes... and was on going for at least 4-5 months.

    although we think it was the Editor UI animations that you can uncheck in Settings. After I unchecked it, it stopped happening... but no one knows for sure if that was it. Seems like it...

  • That or the preview buttons sometimes stop working for no apparent reason and I have to restart C3.

    If you launch the preview and immediately close it while it's still loading - there is a good chance that the preview button will stop working.

    There is a new bug that's driving me crazy. When I'm editing a large table (array), sometimes it starts scrolling up by itself. The only way to stop it is to close and reopen the array editor.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)