Unsupported Android Devices

    Hello, when I exported the APK for Android and Google Play I found out that a lot of Android phones and tablets cannot run the game created with Construct 3. Same happens with all the major Android Emulators that I tried.

    The main reason for this is this message:

    Software Update Needed

    On Android fix this by making sure the Android System Webview app has updates enabled and is up-to date.

    Missing Features: WebGL

    Is there a way to make the APK exported from Construct 3 less restricted?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads

    This happens also with relatively new devices with Android 8.1 installed. This is quite restricting. When I check the WebView version it tells me that it is up to date

    Can you paste the full text of the error message? It includes more diagnostic information at the bottom.

    It should work for any Android 5.0+ device that has been able to update from Google Play and time in the past ~3 years. Why a device might have gone that long without any updates is a mystery.

    Here are a couple of examples from devices with Android 7 and Android 8.1.

    In addition when Google Play performs the pre-launch test, a lot of devices with Android 6 and Android 7

    shows a similar screenshot.

    Mate 9 Android 7: Missing Features: WebAssembly

    Nexus 5X Android 8.1: Missing Features: WebGL. User Agent: Mozilla/5.0(Linux, Android 8.1.0)

    Some of the technical details aren't showing in the screenshots. Can you scroll down and show that?

    Note emulators may not be supported since usually they don't have a real GPU so don't support WebGL. You should only test on real devices.

    Dear Ashley

    here is the whole article

    Software update neededThis content is not supported because your device's software is out-of-date.

    On Android, fix this by making sure the Android System Webview app has updates enabled and is up-to-date.

    Missing features: WebGL

    User agent: Mozilla/5.0 (Linux; Android 5.1.1; SM-J200F Build/LMY47X; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/86.0.4240.99 Mobile Safari/537.36

    If you can help from here, I'll delete the thread below

    construct.net/en/forum/construct-3/general-discussion-7/webview-problem-157705

    Not every user comments on a good game, but my game gets angry when it doesn't open on their phones and gives 1 star. When exporting, I do it in 5.1 (lollipop) format. Is increasing the min sdk a workaround?

    Please don't post the same message in multiple places, as per the Forum & Community guidelines. Closing this thread.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)