Rare editor bug.

0 favourites
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Something like this https://developers.google.com/web/tools/chrome-devtools/javascript/snippets could also work, and would be much less troublemsome than an extension

  • DiegoM this looks promising.. thanks!

  • It would be very useful to get a copy of the data that is causing problems

    DiegoM I think you can see this is his screenshot - cropped below - has most of the layout data:

    Looks the 'middle' has a frame height and width = 0, and size = 0. 'layersBar' which is docked at the bottom of 'middle' has a size = 'infinitypx' ('middle' height causing a divide by zero error?).

    Maybe you could catch size=0 or infinity when loading the layout, and reset to default in that case.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • DiegoM Thank you so much for caring, what you just did is infinitely better than just tagging a "no repro". Twice.

    Ashley, you see? There is a problem. There is a fix. I felt really bad about how you handled this situation, and Diego gave me what I needed, which is looking thoroughly through my report, seeing something is off, because I clearly gave enough information to do so and then providing at least some sort of help, at least until the problem is fixed. Diego is making me stay. You almost made me leave. Twice. Still respect you though. C3 is something I care about, and it was hurting me to leave.

  • Our policy is to close bug reports that are not actionable. I'm afraid until there is something actionable there is still nothing we can do. This thread so far only provides some theories and ideas to follow up - it's still quite a long way from being able to solve the problem.

  • Well then. You made me leave thrice. Strike out, "Scirra".

  • Any acknowledgement to the screenshots or what simstratic suggested would be great. Even if the comment was "those screenshots look like normal behaviour unfortunately".

  • hellow dupuqub

    i was reading this story and I am no coder nor programmer and i don't have such knowledge but it looks like this issue is only happening in your pc. So if were in your place then i would definitely try few things

    1) Logout from chrome sync (I mean logout from google account). I don't know why but this method helped me once with my browser issue.

    2) Try to run c3 in another pc. if it working there then definitely the problem is in your pc and I would try my third and last options which always worked for me.

    3) Reinstall Windows.

  • luckyrawatlucky Hi, in some messages I posted that I already reinstalled windows twice, also that I clean installed Edge and Chrome with no synch. The problem is definitely only on my pc. Thanks.

  • dupuqub from google synch I mean you need to log out from google (synch word I used so you can know which account I was saying to logout). turn off synch will do nothing.

    because you did reinstall windows twice but not worked then I am 99% sure that if you logout from google account then it will definitely work. and also remember when you remove google account from chrome it will ask you to clear bookmark, history etc from this device then you have to check this so data will be cleared. After that it will work.

    let me share you my story about why I think this will work. 7-8 years ago my browser was showing me weird fonts on every website, Gmail, google, yahoo etc. even some cloud applications too. I tried lots of things like you doing now but nothing happened I also tried windows reinstall. After windows reinstall it was working fine but after few hours it comes back I didn't realize how it was coming back I did windows reinstall many times then I realize when I log in to google account after few minutes I got that weird fonts again. Then I just did logout from google account and weirdness was gone. This is why I am suggesting you to remove google account from chrome.

  • lucky, I did that, many times. I understand what you mean. I cleared both Chrome and Edge several times. It fixes the issue, but at random days when I open the editor, there it is.

  • For the sake of closure, I have moved on from C3. If anyone can lock this thread, please feel free to do so to save time and effort from other users. It seems no one will ever be able to get anything good from this thread since there is no fix in the horizon, and also I'm the only who gets this bug.

    I wish you all the best.

  • Jase00 For the record, I regret my last post. I should have just said 'hey some of the layout data is in his screenshot' and left it at that. But sometimes I get carried away, which I did in this case, and I apologize to the Construct team for it.

    AFTER I made that post I found Construct already catches that error, that's why instead of blowing up, it shows the screen including "oops there was an error try ... clear your browser cache", which does indeed solve the problem. In other words - what I suggested - they are already doing that.

    If it's related, and I stress IF, it probably gets them no closer to the root cause anyway (why is the size being saved as 0 in the first place) and that's when it all becomes speculation. Right now off the top of my head I could throw in a dozen different theories based on my experience elsewhere. These theories have nothing to do with Construct itself, and could be practically impossible for Construct to replicate, even with a huge commitment of time.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)