R151 started crashing

  • It was working alright for a day, now it shows this when i start the engine...

    Error report information

    Type: unhandled rejection

    Reason: Error: Cannot read property 'ǃpIN' of null TypeError: Cannot read property 'ǃpIN' of null at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:320867) at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:322022) at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:322022) at Function.ǃpRc (https://editor.construct.net/r151/main.js:2:319983) at Object.ǃKzk (https://editor.construct.net/r151/main.js:159:47933) at Object.ǃKzk (https://editor.construct.net/r151/main.js:159:48085) at Object.ǃwBY (https://editor.construct.net/r151/main.js:159:45308) at async s (https://editor.construct.net/r151/main.js:159:91122) at async editor.construct.net/r151/main.js:159:93147

    Stack: TypeError: Cannot read property 'ǃpIN' of null at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:320867) at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:322022) at Function.ǃpRz (https://editor.construct.net/r151/main.js:2:322022) at Function.ǃpRc (https://editor.construct.net/r151/main.js:2:319983) at Object.ǃKzk (https://editor.construct.net/r151/main.js:159:47933) at Object.ǃKzk (https://editor.construct.net/r151/main.js:159:48085) at Object.ǃwBY (https://editor.construct.net/r151/main.js:159:45308) at async s (https://editor.construct.net/r151/main.js:159:91122) at async editor.construct.net/r151/main.js:159:93147

    Construct 3 version: r151

    URL: editor.construct.net/r151

    Date: Thu May 30 2019 16:14:22 GMT+0530 (India Standard Time)

    Uptime: 0.6 s

    Platform information

    Browser: Chrome

    Browser version: 74.0.3729.169

    Browser engine: Chromium

    Browser architecture: 64-bit

    Context: browser

    Operating system: Windows

    Operating system version: 10

    Operating system architecture: 64-bit

    Device type: desktop

    Device pixel ratio: 1

    Logical CPU cores: 4

    Approx. device memory: 8 GB

    User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36

    C3 release: r151 (beta)

    Language setting: en-US

    WebGL information

    Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)

    Numeric version: 2

    Supports NPOT textures: yes

    Supports GPU profiling: yes

    Supports highp precision: yes

    Vendor: Google Inc.

    Renderer: ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)

    Major performance caveat: no

    Maximum texture size: 16384

    Point size range: 1 to 1024

    Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_compressed_texture_s3tc_srgb, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context

    After restart it starts working, but as soon as i change something in an event it crashes again...

    i was using beta version for the new "wait for previous" action , and now i am unable to work on my project. i am wondering, is there any way to revert my project back to r150 ?

    Or any way to fix this issue? or do i have to wait till the next release...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Please report any such issues on the bug tracker following all the guidelines otherwise it cannot be investigated. Beta releases are for testing purposes and can have stability issues so we recommend backing up any important projects you use with beta releases. (As with any digital work, it is important to take regular backups anyway.)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)