Problem signing APK

  • Hello, please help, I have problems signing the APK, when I sign my project, an error window appears, and I don’t know what to do, I tried several times and again the error.

    Thanks in advance for your reply.

  • What is the error?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hello, the problem arises after creating a new keystore, when I specify the keystore, key name, key store password, key password and click "next", a process occurs in the lower left corner, after which an error appears:

    Error: Failed to load signer "signer #1"

    java.io.IOException: Failed to obtain key with alias "keygame" from tmp/e75e1690-3678-4248-9f5d-f8eb4c736795. Wrong password?

    at com.android.apksigner.ApkSignerTool$SignerParams.loadPrivateKeyAndCertsFromKeyStore(ApkSignerTool.java:690)

    at com.android.apksigner.ApkSignerTool$SignerParams.loadPrivateKeyAndCerts(ApkSignerTool.java:555)

    at com.android.apksigner.ApkSignerTool$SignerParams.access$200(ApkSignerTool.java:509)

    at com.android.apksigner.ApkSignerTool.sign(ApkSignerTool.java:215)

    at com.android.apksigner.ApkSignerTool.main(ApkSignerTool.java:89)

    Caused by: java.security.UnrecoverableKeyException: Get Key failed: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.

    at sun.security.pkcs12.PKCS12KeyStore.engineGetKey(PKCS12KeyStore.java:435)

    at sun.security.provider.KeyStoreDelegator.engineGetKey(KeyStoreDelegator.java:96)

    at sun.security.provider.JavaKeyStore$DualFormatJKS.engineGetKey(JavaKeyStore.java:70)

    at java.security.KeyStore.getKey(KeyStore.java:1023)

    at com.android.apksigner.ApkSignerTool$SignerParams.loadPrivateKeyAndCertsFromKeyStore(ApkSignerTool.java:663)

    ... 4 more

    Caused by: javax.crypto.BadPaddingException: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.

    at com.sun.crypto.provider.CipherCore.unpad(CipherCore.java:975)

    at com.sun.crypto.provider.CipherCore.fillOutputBuffer(CipherCore.java:1056)

    at com.sun.crypto.provider.CipherCore.doFinal(CipherCore.java:853)

    at com.sun.crypto.provider.PKCS12PBECipherCore.implDoFinal(PKCS12PBECipherCore.java:405)

    at com.sun.crypto.provider.PKCS12PBECipherCore$PBEWithSHA1AndDESede.engineDoFinal(PKCS12PBECipherCore.java:437)

    at javax.crypto.Cipher.doFinal(Cipher.java:2164)

    at sun.security.pkcs12.PKCS12KeyStore.engineGetKey(PKCS12KeyStore.java:371)

    ... 8 more

  • Are you sure you got the alias and password right? The error is saying those might be wrong.

  • Yes, I tried several times.

    used a password with 8 characters.

  • I also tried countless times, but now I got it right and I'll tell you how. I put it to build the application in version 6.0+ (Marshmallow), I put Alias ​​(nickname) as the name of the keystore, and the same passwords for both fields. I realized that the flaw is in the Android version of the application. Try to do it the way I described. Cheers!

  • Yes, same password in the two fields, that works for me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)