Preview not working on mac.

0 favourites
  • 10 posts
  • Since the last update, preview isn't working for games using the construct 3 Runtime. And i mean all the projects, not just mine. i tried previewing kiwi story and others and all i get is a black screen. I found out the reverting to construct 2 runtime solves the issue, but i had to use the move to behavior which prevents me from reverting to c2 so i'm stuck with a blank screen.

    I can post my computer specs if they are relevant but i don't even know if this is the right forum for this.

    Any help on this matter will be appreciated.

  • I just tried Safari and Chrome on Mac and both worked fine.

    Which browser and OS version are you testing on? Do other browsers work?

    If the preview window isn't loading and you press F12, are any error messages listed in the browser console?

  • macOS Mojave v. 10.14.6

    browser: chrome

    i'll try on a different browser and report back

  • safari is working fine.

  • tried posting an image with the f12 screen, but for some reason it isn't showing.

    *reuploded it, image showing now

  • by the way, i am getting some weird artifacting on safari the edit effect button is expanding to 100% of the viewport for some reason:

  • still not working after updating chrome and the OS. Now using Catalina 10.15.2.

    Works in Firefox but after a while it gets incredibly slow.

    Works in safari.

    Can't preview in chrome.

    Can't preview when installed as an app.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • We will need a bug report following all the guidelines to investigate this. Unfortunately it is impossible to help from this information alone.

  • I understand.

    I considered doing that, I read the guidelines the day i originally reported this. But i am having issues making the bug report useful too, i can't send a project because it's happening with all the projects, even the ones downloaded directly from your site.

    I tried previewing kiwi story, demonoire, glokar, etc.

    None of them work. I thought it would be me being behind a few updates, so i updated to the latest chrome and OSX versions with the same results.

    Then i tried in safari, firefox and opera. All of them work fine, chrome still doesn't.

    I also thought about sending video of the issue, but the guidelines discourage the use of video. I'm not sure what else i could add in a bug report that i haven't already mentioned here. I understand it's not possible to fix an issue that can't be reproduced but i am at a loss of how else i can help matters.

    A full system report?

    The steps to reproduce are simple: download project > open project > preview.. C3 worked before the past 2 updates and then it suddenly stopped working.

    I guess i can just use some other browser.

  • Nevermind, the last update from a few hours ago fixed whatever the issue was.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)