Multiplayer not Working After Signing in C3

  • I use multiplayer in my game, it works ok in debug apk but when i sign and compile with C3 it shows signalling disconnects. (it was working great a few days back though)

    I strongly feel there is something wrong with Signing in C3

    Edit: Also not working when i compile an unsigned release apk and compile it on my own!

    Please help team Scirra.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ok i have tested it like four times now, i am pretty sure there is something wrong with C3 compiler and here are my observations so far...

    Multiplayer signalling connects when i compile to a debug apk

    It Does not when i compile to a release apk or a signed release apk

    Please help me as my game is published and not connecting (multiplayer not working) and i cannot even return to an older apk due to version code being old and i have tried also compiling old versions of my game too and they are showing the same result of multiplayer not working.

    To sum it up, there is something wrong with release/signed apk compilation with c3 (debug apk working fine) which is causing multiplayer signalling to not connect, please fix it or tell me what else to do to solve this problem!

  • this is where you submit bug reports

    github.com/Scirra/Construct-3-bugs

  • yoyoEleanor

    Just posted a bug here

    github.com/Scirra/Construct-3-bugs/issues/2710

    Hope they resolves it very soon as my game is published and it is not working.

    So Please scirra team resolve this now.

    Thank you

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)