Layout/Project Preview is not working properly?

  • Hello everyone.. im having problem with the Layout/Project Preview

    when i run the Layout/Project preview, It looks like some part of the layout is not touchable/clicked.

    So i made a new simple project just to show you guys what really happened. see the screenshots below..

    When the blue box is touched, the blue box will be destroy.

    But some of the blue box at the right and the bottom of the screen cannot be touched/clicked. and it cant be destroyed.

    It looks like the Area in the red color i marked is NOT touchable/clicked.

    Does anyone have a same problem? or its just me..

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm using mouse all the time but I've never encountered this problem. Perhaps there's a flaw in your logic?

  • i used mouse to test it in the layout/project preview.

    im not sure.. it working just fine a few days ago.

    However, when i export it to the Debug.Apk, it working just fine on the phone..

    all the boxes can be touch and destroy.

    This problem only happen in the layout/project preview.

    If your browser is working just fine.

    Then it must be something wrong with my browser..

  • Be sure to actually post the example project so people can reproduce the issue.

    Simply with screenshots, it is just a guessing game.

  • Well, that's strange. Wanna post a screenshot of your logic or the test project file?

    Tried to recreate what's visible on your screenshots and everything works fine in preview as well as in remote preview with firefox and chrome.

  • Here is the link project, download it from the google drive.

    i create a very simple one just to test it.

    drive.google.com/file/d/1mXGDPxd2UojwIdsSgBmz_VT6ufI8-fEd/view

    and here is my video link with the problems..

    youtu.be/dY6bVGZF9wk

    as you can see, i cant click on those blue boxes at the right and the bottom of the game.

  • Works fine here for me. I Can click all the boxes, at least when using a mouse. I don't have my tablet to test touch at the moment.

  • Can't reproduce your problem in chrome or firefox. Are you using the C3 runtime? I did the tests using the C2 one.

  • PROBLEM SOLVED!

    when running the Project Preview on browser.

    I must accidentally pressed the [Ctrl]+[-] button on my keyboard.

    So the browser is shrinking the 'game interact area size'(I dont know what is this called)

    but the display is not changing size.

    Thats why i cant click those blue boxes at the right side and the bottom of the screen.

    By pressing the [Ctrl]+[+] button, and adjust the display to 100%, now i can click on all the boxes.

    Thank you for helping me do the test..

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)