Layout objects deformation when I resize editor bars.

From the Asset Store
Health, Weapon & Rage Bars for your Games. Easy to use & Customize.
  • I don't know if it is a bug or not but before submitting a bug request I would like to have your opinion.

    When I enlarge the "properties" bar the content of the layout unexpectedly change the proportion.

    Just to make you an example. This is the default configuration:

    Now I resized the Properties bar, look at the objects of the layout:

    I enlarge as much as I can the bar:

    The same happen if I add the "Find results" bar at the bottom of the window, look at deformation of the objects and the shifting of the placeholders into the layout:

    Resetting the configuration doesn't solve.

    I have also tried to open Chrome with extensions disabled but nothing to do...

    Firefox seams not affected by the problem.

    It doesn't matter which C3 version I use.

    Any idea on what can be the cause of this?

    thanks

  • I am not able to reproduce this issue. Have you tried updating your graphics card driver to the latest version?

    What operating system are you using?

  • DiegoM, it is an old HP EliteBook 8440p with Window 7 with an intel HD graphic.

    Checking with the intel automatic update says I'm using the updated driver.

    I'll see if there is something else but considering it is on the road since years I do not expect to find something new. I will back to you again for an update.

    Please let me know in case you want me test or configure something else.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • A quick Google shows the device was released around 2008, so it's around 12 years old. That's pretty old, and unfortunately probably means no further software updates are available for it. The screenshots look like a graphics driver bug, so it may be that there is no solution other than to switch to a newer device. There is a chance you can get a newer driver directly from Intel that's not available on Windows Update though, so it's worth looking.

  • Ashley I do agreed with you, but as promised I did back with an update and a workaround.

    Just to recap my troubleshooting I would inform you that I tried to go back with at least 3 different video driver releases with no results.

    Any other configuration setup was not giving me a solution.

    What actually solved was to disable Chrome hardware acceleration.

    This solved the problem but the question now is what kind of bottleneck is now been introduced? since we are talking about a 12 year old hardware probably none, but I do not exactly know what the hardware acceleration may actually improve into a so old hardware.

    I'd appreciate your opinion on this or what else you may suggest I may check into the chrome://flags that might tune this strange behavior.

    thanks a lot for your time.

  • Well, that basically confirms it's a GPU driver bug. It means it will now be using software rendering and not using the GPU at all. It'll be slower, but at least it will look right.

  • it looks like but I don't have the same problem using Firefox. Does it might exclude a driver problem in this case?

    Is there something into the Chrome flags with which I might play to try to disable something more specifically instead of disable the whole hardware acceleration?

  • Driver bugs are random, and each app uses the GPU differently, so it still makes sense if it works in Firefox but not Chrome. You could just use Firefox if it works there.

  • I did find a good solution to my problem.

    I have enabled hardware acceleration and I played a bit with the flags.

    The one to which I pointed my finger was this one:

    "Choose ANGLE graphics backend"

    Choose the graphics backend for ANGLE. D3D11 is used on most Windows computers by default. Using the OpenGL driver as the graphics backend may result in higher performance in some graphics-heavy applications, particularly on NVIDIA GPUs. It can increase battery and memory usage of video playback. – Windows

    This flag has the following options:

    - Default

    - OpenGL

    - D3D11

    - D3D9

    - D3D11on12

    I've tried all of them and here are the results:

    - Default --> has the problem --> game speed OK

    - OpenGL --> it is OK --> game speed slow

    - D3D11 --> it is OK --> game speed OK

    - D3D9 --> has the problem --> game speed OK (this is probably used as default)

    - D3D11on12 --> it is OK --> game speed slow

    It seems the right configuration form my PC is D3D11.

    I don't know if this might tell you something but at the end solved my issue.

    Thanks for your help

  • Unfortunately I've found another problem.

    D3D11 that apparently was working fine and solve my problems doesn't work properly when it should render particles effects while in runtime or preview particles into the editor.

    So, at the moment I have no choice than to select D3D9 that render everything but cause the layout editor aberration when resizing bars. (sigh...)

    Does anybody know what other Chrome parameters may I change to try to fix my problem?

    thanks

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)