Image Lines appearing seemingly randomly

  • Hey all, I've got a bit of an issue. Sprites in my game get very noticeable lines around the edges and I'm really not sure why.

    I've tried a lot of things like resizing, re-importing the images, etc. but it just seems to randomly occur. One sprite might be fine for a few days, then suddenly it has seams and a few days later they're gone again. They appear in the game editor and preview, but not in the sprite's image editor.

    Examples:

    Does anyone know what's causing it? I've built a rather extensive game engine over many months and I'd really like to get a game out of it while I'm stuck at home because of lockdown, but I don't want to start paying an artist until I can be sure this won't be an issue. Thanks in advance!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have seen that before - I think the fix is to put a one pixel transparent boarder around the edges of the images. You can automatically do that in the C3 image editor by clicking crop button.

  • I have seen that before - I think the fix is to put a one pixel transparent boarder around the edges of the images. You can automatically do that in the C3 image editor by clicking crop button.

    Thanks for the reply! I tried cropping the images and even adding more empty space, not none of it worked. I did find that if I change the Sampling option in the properties menu from Trilinear to Nearest the issue disappeared, but the images go unbearably grainy.

    I think I may need to submit it as a bug.

    EDIT: After checking thoroughly through the manual I saw it mentioned that it might be an issue that can be resolved by turning the Downscaling Quality option to High. This did indeed fix the issue for me, although apparently at the cost of a lot of extra memory.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)