FPS Dropping randomly every few seconds

  • Just curious - is anyone else getting a FPS drop of about 10-15 every ~5 seconds or so? My cpu is constantly hovering around 15%, so I know it's not that. There are maybe 100 objects on the screen, and the memory is probably no more than 100mbs (I also have a high end i7 with 64 gig of RAM and a 1080 GTX card).

  • Just curious - is anyone else getting a FPS drop of about 10-15 every ~5 seconds or so? My cpu is constantly hovering around 15%, so I know it's not that. There are maybe 100 objects on the screen, and the memory is probably no more than 100mbs (I also have a high end i7 with 64 gig of RAM and a 1080 GTX card).

    Is this in preview or exported ???

    I ask as Ive noticed previewing with C3 can sometimes give a rather choppy performance compared to the old C2 preview. Probably related to the editor and preview running in the same browser. The browser preview also seems to be drastically affected by other external programs running especially ones that access the internet regularly. eg ive noticed Spotify moving to next track can cause up to a temporary 20-50% hit in framerate while previewing.

    However anything actually exported though, eg to HTML running from website or NWJS app run real smooth.

  • NetOne - this is preview. I haven't tried exported yet (as I'm still waiting on the C3 runtime, so it's a bit of a moot point)

    I'll try exporting it and see if I have the same issue.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • NetOne - good call; it seems to be much smoother on export. Thanks!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)