Error Firebase Google Login Authentication Pupup Disappears

  • Hi everyone, I've been trying to solve the problem for two weeks or more and there's no way.

    When I try to log in with the google account in android .apk the popup appears quickly and in the same shelf disappears.

    Does anyone have a solution for this?

    I Work in construct 3. I found a post from a user who has the same problem ... but I think he didn't find the solution. Can anyone give me some light?

    Thanks in advance

    Note: It works perfectly on the web page.

  • Hi, I don't really recommend logging in to a native mobile app (Android or iOS) using web app authentication of Firebase, like what you're using. It has been long depreciated by Google and Apple. There is no guarantee that it will work anymore.

    You should use native authentication, like what we use for PlayFab + Mobile Facebook or Mobile GooglePlus.

    But, if you have your reasons, try this:

    Usually this happens when there is only a missing app configuration from the Firebase Console, try this, skip the code parts. And, don't forget to whitelist the localhost.

    Let me know if it still doesn't work, I'll try to help as I can, if you provide more information. Good luck!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thank you very much for your quick response.

    He searched for information about playFab and is interesting and could later incorporate this system that he does not know. I am quite new to this. I also have to say that I already have everything done in Firebase with bbdd and which has taken me months of work and now that I finally have it, that in browser it worked perfectly, I create the Google Play tab and what is my surprise when I install the application? log in. :(

    Now I'm going to try what you tell me about adding to the white list in Firebase, although I don't know how to add a domain to the white list in Firebase, I'm going to investigate and tell you!

    many thanks!

  • Usually this happens when there is only a missing app configuration from the Firebase Console, try this, skip the code parts. And, don't forget to whitelist the localhost.

    I don't know how to do this part....What do I have to do avoiding the code?

    and, I think I have already added the localhost to the white list...

    see:

    ibb.co/7RGyW4p

    thanks!

  • Sorry for the late response. The localhost not getting whitelisted is the usual cause. But yeah, your case seems to be different.

    Could you answer these, so we can trouble shoot:

    1. How did you implement Firebase? Did you use the Scripting Feature?
    2. Are you using the Google Play plugin? If it's not configured properly, it could return an error.

    Then,

    Follow the instructions here, on debugging your mobile android application.

    From the Chrome Developer Tools :: Console, while your device is connected to your mobile Android device on USB Debugging, running your debug .apk, after the Google Authentication window closed. Look for errors in the console, then screenshot here, so we can see what's the issue.

    Good luck!

  • Thank you so much for help me! I appreciate it so much.

    Sorry for not answering before, I was busy.

    About your questions, I implemented Firebase in my construct 3 project. I didn't use command function.

    Question 2: I think if I am using google play correctly ... I added the google play service. Although I don't know if you mean any addon of c google play of cosntruct 3 ..

    I will try the solution that you tell me later and update the post!

    many thanks!

Jump to:
Order by:
Duplicate Topics
Posts
Views
Last Post
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)