Editor Locks Up on iPads

0 favourites
  • 3 posts
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Hi, everyone. I'm a bit under the gun here as we had to switch from using Unity to Construct 3 in my high school game development course with everyone staying at home. Most of my students are using school-issued iPads to work on their projects but we have run into a snag.

    C3P files that work perfectly fine when run from my PC in Construct 3 cause the iPads to lock up with an error. When you hit the Preview button you get "Failed to start preview. Try reloading Construct 3 before trying again". We are running Construct 3 in Safari and Chrome with the same result. When I click the OK button, another window pops up saying "Preparing images (87.5%)" and that's it. I eventually have to quit out and restart Construct 3.

    Needless to say, this is frustrating the kids and home and disrupting the whole process. I've tried to scour the boards here, but nothing seems to touch on this issue. Anybody have any suggestions? There's only about 3 weeks of school left and they need to make their final projects. Thanks.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Here's a little flow-up to the story. I accidentally left my iPad sitting there with the locked-up editor sitting there with the "Preparing images 87.5%" still on the screen. Down in the bottom left corner of the screen in the dimmed area it said Creating textures (6 remaining), but when I came back to it it said 11 remaining. I left it alone and now it says 23 remaining. So . . .

    • I guess it's not locked up but processing something incredibly slowly
    • The tasks remaining are increasing over time and that's not promising

    Does any of this speak to anyone?

  • That shouldn't happen and I've never heard of anyone else having the same problem.

    I'd advise filing an issue following all the guidelines: https://github.com/Scirra/Construct-3-bugs

    Note we need all the requested information to be able to help.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)