Disable mouse zoom in editor

From the Asset Store
All popular touch mechanics - scrolling, zooming, swiping
  • Hi folks. Upgraded to C3 from C2 a while ago (largely because I wanted to migrate to Mac from Windows).

    One issue I've been having that drives me insane is constantly "accidentally" changing the zoom level (eg. in the event view). CMD + mouse scroll gesture on Mac changes the zoom (which means every time I press CMD to copy and paste, undo, or any of a bunch of common actions) I am constantly accidentally changing the zoom level when I touch the mouse even a little tiny bit. It's WAY too sensitive too, so the tiniest touch causes me to zoom WAAAAAY out and then I waste loads of time trying to zoom it back to where it was. Quite distracting when you're trying to think about event logic :(

    I think there's a hotkey to change it back (not that I remember what it is), but honestly, I basically never want to change the zoom level anyway. Can I not just disable the CMD+mouse scroll zoom thing? I can't find the option anywhere.

    I hope I'm just being blind but any help would be appreciated :) Thanks.

  • This is a great idea! I find this happens all the time now that I'm on a trackpad, but I've just been dealing with it (I thought it was a browser accessibility issue).

    If it has to be a suggestion on the ideas platform, you'll have my votes

  • Yeah, I think it might have to be. As far as I can tell there's no way to do this. You'd think the ability to customise hotkeys to your own preferences would be an obvious feature to add :(

  • This type of zoom is actually related to your browser/OS configuration (especially the mouse wheel sensitivity).

    So you should check if your browser, in its configuration, if you can disable that zoom shortcut.

    The shortcut to get back to 100% original zoom is ctrl (cmd) + 0 (@, not the 0 of the numeric keypad).

  • Thanks for the reply Kyatric, and very grateful for the reminder of the zoom reset key.

    I must say I'm not convinced about the browser/OS settings thing. I don't have this issue with any other program (eg. CMD+scroll gesture does nothing in Chrome, or even in the Construct start page - only in the editor tabs). It seems to be a 'Construct zoom', not a 'browser zoom' (I can trigger a browser zoom separately, anyway).

    I will look into this more however.

  • I've tried a few things, including disabling trackpad zoom in System Preferences and disabling Chrome zooming with extensions, but the event-sheet zoom problem still occurs. No other web pages zoom in/out when holding command and moving two fingers on the trackpad - it certainly feels like a Construct zoom feature, so hopefully it can be an option we can disable.

  • I must say I'm not convinced about the browser/OS settings thing. I don't have this issue with any other program (eg. CMD+scroll gesture does nothing in Chrome, or even in the Construct start page - only in the editor tabs). It seems to be a 'Construct zoom', not a 'browser zoom' (I can trigger a browser zoom separately, anyway).

    I must admit I'm not super familiar with Mac. On windows, ctrl+mouse wheel is the shortcut, in any browser, to control its zooming feature/make the text font bigger in any web page.

    Chrome on Mac is actually the Safari browser, so consider checking Sfari's settings.

    It is "normal" that ctrl(cmd)+mousewheel does zoom in the event sheets, it is treated like any web page in which you can zoom/make the text font bigger.

    I've tried a few things, including disabling trackpad zoom in System Preferences and disabling Chrome zooming with extensions, but the event-sheet zoom problem still occurs. No other web pages zoom in/out when holding command and moving two fingers on the trackpad - it certainly feels like a Construct zoom feature, so hopefully it can be an option we can disable.

    Maybe that is the case.

    If so, consider filling a bug report for our dev team :

    If you run in to a bug or issue in Construct 3, please post it to the GitHub issue tracker here:

    https://github.com/Scirra/Construct-3-bugs

    You must follow the bug report guidelines or your issue will be closed without investigation.

    If you have suggestions for new features or improvements in Construct 3, we have a feature suggestion platform here which lets everyone vote on their favourite ideas. You can find out more in this forum thread about posting suggestions.

    Your must follow the suggestion guidelines or your suggestion may be declined.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Chrome on Mac is actually the Safari browser, so consider checking Sfari's settings.

    Uhhhh... what? Chrome isn't Safari. Chrome is Chrome, Safari is Safari.

    In any case, I have looked through every browser & OS menu I can find and haven't been able to disable this behaviour. It really seems like a C3 issue.

  • Uhhhh... what? Chrome isn't Safari. Chrome is Chrome, Safari is Safari.

    Chrome, on Mac, is Chrome's interface using Safari's engine.

    Which makes it, basically, Safari disguised as Chrome.

    At least it was the case a couple of years ago.

    In any case, I have looked through every browser & OS menu I can find and haven't been able to disable this behaviour. It really seems like a C3 issue.

    Have you filled a bug report ?

  • Chrome, on Mac, is Chrome's interface using Safari's engine.

    Which makes it, basically, Safari disguised as Chrome.

    At least it was the case a couple of years ago.

    I can't find any reference to this having ever been the case and I don't believe it is the case now. (Not necessarily saying you are wrong but I have never heard this).

    Have you filled a bug report ?

    Well, I don't know that it is a 'bug' with the software as such, just an accidental cross-platform UX snafu. CMD+mouse wheel is supposed to change the zoom level as an intended feature. It's just that on an iMac mouse (which doesn't have a wheel and instead relies on gestures for scrolling) it gets misinterpreted, causing unwanted zoom behaviour.

    I can't think of any way of fixing this "bug" other than simply allowing the user to disable the hotkey if it bothers them, which seems more like a new feature than a bug fix. To that end I have proposed it on the Ideas board. Do you think I should file it as a bug as well?

  • Do you think I should file it as a bug as well?

    Yes.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)