Construct 3 crashes 90% of the time when I try to save

  • Title says it all. I have tried saving to Google Drive, saving to Local Browser, and saving a downloaded file. Most of the time, it crashes and says something went wrong. I cannot recover my work. I have spent the past 2 hours re-making the same project probably 10 times.

    I am using Google Chrome 65.0.3325.146 (Official Build) (64-bit) on Ubuntu Linux 17.10.

    I just paid for Construct 3, so this is rather disappointing.

  • I have not heard of this issue before.

    Have you tried clearing the cache (I am not sure if this works) and checking if you have the latest version of stable Chrome (without plugins), stable C3 and a new project? Or perhaps try Firefox?

    What else you can try: follow the guidelines here to post a bug, so that perhaps the Scirra team can investigate this issue.

    https://github.com/Scirra/Construct-3-bugs/issues

  • Yes, I just made sure the system was up to date (sudo apt-get upgrade -y; sudo apt-get autoremove --purge), cleared all Chrome cache (including Hosted App Data), and did a reboot. When I loaded Construct 3 back up, it crashed the first time I tried to save.

    Edit:

    I also downloaded the 'stable' Windows editor to see if it could save. I didn't even make it that far - the preview is completely black and does not work.

    Tried Chrome on Windows, same preview issue. Also same saving issue.

    Tried Incognito mode - also crashes.

    This is really unacceptable. How do I reach out to someone official to request a refund?

  • email: support(at)scirra.net

    As your post/problem is so very rare, the likelihood is that the problem lies within your system - gpu drivers for instance.

    Any error messages would help considerably.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks.

    I'm willing to provide any information necessary to assist in troubleshooting. I'd rather have the issue resolved.

    I have experienced this same issue across multiple computers. Chrome displays the 'Aw Snap...something went wrong' message with no more information. Is there a way to get a log from Construct 3?

    My current computer configuration is:

    • CPU: Intel Xeon E5-2428L (x2)
    • RAM: 96GB
    • Video Card: NVIDIA Quadro K2000D
    • OS: Ubuntu 17.10 x64 running Gnome 3.26.2
    • Kernel: 4.13.0-37-generic
    • NVIDIA driver version: 384.111
  • In regards to issues with Construct 3, please visit the bug database and make sure your bug was not already reported.

    If it was, you may add informations as comment to the ticket.

    Otherwise create a new report and fill all the informations required to allow our devs to investigate in order to fix in the next releases of Construct 3.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)