Chrome OS editor issues

0 favourites
  • 5 posts
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Does anyone have experience running the editor on Chrome OS? I have a brand new Lenovo chromebook and a 6-month old Asus chromebook that both manifest the same two issues on multiple projects (including some of the demos, such as Golf):

    1. Screen blacks out and then comes back to an empty preview window when using any sort of mouse/touch drag/hold feature

    2. Layout editor always eventually crashes with the little frowny-face icon

    Per the team response(s) [to bug reports] I suspect these are related but I don't know where to go from here. Both devices are fully updated and other WebGL software that I've tried runs without a hitch...any suggestions on next steps?

  • Have you installed any available system software updates?

  • Do you have extensions running and/or other tabs open?

    Can you run it in an incognito window?

    My new 3D game VAULT OF PERIL (on the Scirra Arcade) was made entirely with a fairly low-end Chromebook (Celeron, 4GB RAM) and was a pleasant experience (no crashes, responsive performance). I have 11 extensions running and, maybe, 2-4 other tabs open when using Construct.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I appreciate the feedback...

    I tried removing all extensions, resetting Chrome, incognito, browse-as-guest, and even did a factory reset. System and apps are all updated - however, I still have the same issue.

    This time I get an error message in the developer tools (below.) This was all tested with the "Instant laser hit" demo project.

    [.WebGL-0x50897900]GL ERROR :GL_OUT_OF_MEMORY : glTexImage2D: <- error from previous GL command local.html:1 [.WebGL-0x50897900]GL ERROR :GL_OUT_OF_MEMORY : glTexImage2D: <- error from previous GL command [.WebGL-0x50897900]GL ERROR :GL_INVALID_OPERATION : glGenerateMipmap: <- error from previous GL command local.html:1 [.WebGL-0x50897900]GL ERROR :GL_INVALID_OPERATION : glGenerateMipmap: <- error from previous GL command WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost canvasManager.js:31 [Construct 3] WebGL context lost runtime.js:66 [Construct 3] Suspending local.html:1 WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost canvasManager.js:32 Uncaught (in promise) TypeError: this._LoadWebGLShaderPrograms is not a function at CanvasManager._OnWebGLContextRestored (

  • It looks like a problem with the device's graphics driver. You'll need to contact Google or the device manufacturer about that.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)