Can't open my project (New built in function BUG)

  • Ashley I'm seriously angry because I've spent 1 week trying to find a bug in my project which resulted in black screen. In debug mode it was all loaded, but nothing was showing.

    After 1 week I've gave up and tried another project, the same happened. Now that I had a clue about what was causing all of this, my project now fail to load every time.

    So, I find out we have a really serious problem about the new built in function when you start to copy functions from one project to another. It results in invalid functions calls and somehow is blocking the entire game to load, but this time I can't even start my project.

    I genuinely expect a quick solution to my problem. It's an absurd. I've so little time to work on my projects and now, in the middle of the weekend, I can't do sh**t because a project breaking problem like that is in the stable release.

    And before start with ceticism and say I'm using loops wrong or whatever, I can provide the project for a quick solution, just tell me how, please.

    Tagged:

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If you have a project that needs recovering you can send it to me at ashleyrka@scirra.com and I'll see if it can be recovered (but I can't guarantee it always will). Remember it's important with any digital work to keep regular backups.

    If there's a serious bug obviously we want to fix that, but we need a bug report following all the guidelines, because posts like this simply don't have enough information for us to act on. For example, does it reproduce in the latest beta release? Perhaps we already fixed it.

  • Ashley It happens sometimes when you open two projects and copy a function to another project. Sometimes It works and sometimes treats it like It was the same project so It increments the function's name, generating invalid function calls. I'll send to you by email then.

    It happens in beta release too. I've tested with the other project which doesn't load but I still can open it. Both projects got this problem because I started to copy functions to them. I'm quiet certain that the problem has to do with it.

    edit: I just sent you the email

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)