Can't load project proper since last update.

0 favourites
  • 4 posts
From the Asset Store
Fantasy Game includes more than 600 sound effects inspired by hit computer games like World of Warcraft and Diablo.
  • Hi, ever since last week I'm fighting with restoring the smoothness of my work, so far to mixed results.

    Ever since the 210, I can't use the desktop build to open my project as a Folder Based project - I updated to last NW.JS, there is no error - the projects loads for a few seconds (Judging by CPU usage in the task manager) then just does nothing...CPU usage falls to 1% and the project never opens. If I open it as a single file, however, the project opens.

    Now, since then I decided to move to the web version (where I'm suffering a lot - its slower, it doesn't save everytime, saves longer and most importantly - I can't use external editor shortcut in the image editor which I use alot) There the project opens 1 out of 5 times... The other 4 attempts to open it, it freezes like the desktop version, but every so often the project loads.

    NOTE: I've tried this on another PC to the same results. Clean isntall and all.

    Now, I've been working this week at full speed, trying to convince myself that this is the new normal and its OK...but its not, and who knows what next releases will change and I risk of losing 4 years worth of heavy work. Can someone please give my issue some thought. ANY help is GREATLY appreciated.


  • Ok, so I tried deleting most of the objects in the game...around 100, adding up to some 3000 + seperate images, and the projects opens like a charm. This was not an issue in earlier versions for sure, as (out of fear of some such future problems) I've stress tested the project and it works perfectly with many more objects and images close to 20 000. Are there any new limitations for some reason?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Have you tried saving as a single C3P file? Does it have the same problems?

    When the project won't load, try pressing F12 and see if there are any errors in the console log.

  • I have yes, and it works fine as a single file. However, for various reasons I prefer the folder format (save, load speed and more importantly - version control). Hitting F12 shows no errors.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)