C3 not responding on mobile anymore?

  • Hi,

    Hope everyone is having a great day. I was using C3 on my android phone perfectly fine a few months ago. But I tried to use it today with the latest update and nothing seems to respond to touch.

    Example i can't select objects or zoom in and out or anything. I meet the requirements. Has something changed to effect performance lately? I can run all the games that i load up perfectly fine and i can get into the menus, but i cant move around the project area zoom or double tap to create sprites ext. or select sprites and move them around. Even creating a blank project i can't do any of these things.

    Anyone else notice or are having similar problems? If so is there a fix?

    Thanks!

  • So I had more time today to dive into this a bit more. Looks like it is something to do with the latest stable build release. I tried using the previous stable build release and everything runs perfectly.

    So must be something to do with the changes in the latest release. Maybe to do with the new C3 runtime? Anyway be aware that if you have the issues I listed above in the previous post. Just use stable r120 release and everything should work fine. Some one may want to look into this. I use an android phone with Android version 7 CPU octa-core 2 GHz and 3 gigs of ram. Thanks! Have a great holidays everyone!

  • Please file any issues on the issue tracker.

  • I've been struggling with the same issue. Tried on Huawei Nova, Samsung Galaxy S6, Samsung Galaxy S9, Samsung Tab A, Sony Xperia ZX and neither reacted to touch. Indeed, it's quite strange, because nothing ibside the layout can be tapped, but outside it lets you double tap for adding an object. Though one cannot select the object once the instance is onto the layout. It is not possible even to scroll the screen.

    Jean-PaulL

    Did you manage to post the bug report? Did you get some feedback?

  • I can confirm this on my moto g6, r128 works fine with zoom or scroll in layout, all versions after this are broken.

  • You are right. On previous releases it keeps working on mobile. The point is I cannot load now my entire project for I saved it and now it says it is a future C3 release project and cannot be opened with previous versions any more!!!!!

    I hope this is being repaired soon, since it could mean losing months of work...

    Did you already post the bug? I'll do this very day if not. Tried even with an empty project to avoid been told it is because some addons or some setup or things alike. So now I can tell it is totally a bug.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Bug reported

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)