No audio on any iphone browser

0 favourites
  • 13 posts
From the Asset Store
This is a single chapter from the Construct Starter Kit Collection and the Student Workbook from the Workshop.
  • As the title says. I imported wavs that where converted to Webm by C3. Yes, I touched the screen and played the game to make sure the browser has registered the 1st input so it has permission to play the audio, but nothing.

    Any ideas?

  • ios support only .m4a

    convert your files to .m4a and add them to your project

  • Thanks for the tip.

    And if I want the sound to be playable on all devices? I have a Webm version, and a m4a version? Construct 3 will pick the right one automatically?, like Construct 2 does?

  • You should only use WebM Opus audio - it's the only format that plays on all platforms. Construct provides its own Webm Opus decoder for iOS so that the format is supported there.

    Audio playback should work on iOS. It's hard to say more without more details, such as a sample project.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Probably not related to your issue, but here's how I am currently getting away using an old 3rd gen iPad (for testing one of my apps). The sounds work even though the system is something like iOS 9.3 (can't update any further cause the hardware is ancient). So this is how...

    I'm using C3 with C2 runtime (advanced settings). Import sounds as m4a files. (You should be able to convert wav files with C2 (if you own it that is, if not Audacity should do the trick; import to C2 and export project to web/html, then locate media folder to grab them). When exporting to html, choose minify mode: simple (none doesn't seem to work; haven't tried advanced), leave the two boxes unchecked to be sure to have it the same as me (deduplicate and recompress unchecked). You can't use features meant for C3 runtime (such as the new functions), so this only works for simple projects.

    C3 will convert the project to C3 runtime every time you launch, so be sure to go to advanced settings to change it each time you start working.

    Oh almost forgot, preview doesn't work. To test, I need to upload all files to my own server.

  • yme Thanks, but downgrading to the C2 runtime is not possible for this game.

    Ashley How do I send a sample project just for you? I cannot publicly post it here since it is a job for a private client.

    More details about this:

    - The audio is available in iPhones, but it has two problems still. The first is that if you leave the browser (to use a calculator on your phone for example) and come back in, the audio doesn’t work anymore sometime (bot not always - not sure why).

    - A user using an iPhone XR with the lastest iOS (14.0.1) could not hear any audio - not sure what browser they used. Likely Safari. On my iPhone 7 Plus with iOS 13.7 the audio is all over the place. It almost never works if I am on Safari, and when I use Chrome sometimes it works, sometimes it is really distorted. Video of the distorted audio, 1st time in my life I see this happening:

    Subscribe to Construct videos now

    youtu.be/wb12KVEsEY0

  • If the problem is really just with your sound files, import them to a fresh new project to demonstrate the problem and share that. It's far easier to help with minimal projects anyway.

    If the problem does not reproduce in a new project, it suggests something wrong with your project (e.g. events that keep trying to manipulate audio and breaking it).

  • Ashley But if it is a mistake of mine, why does the sound works 100% of the time on my pc and android, but only sometimes on ios? I will make a minimal project and try anyways, need to resolve this.

  • Ashley Ok, got you a winner, the minimal project's audio doesn't work on:

    iPhone 6s on iOS 13.3

    iPhone 7Plus on iOS 14.01

    The minimal project is just a screen, and some buttons that play the audio. Drive of the C3 file:

    drive.google.com/file/d/13f8Bxn0P2VGZDIQxxNC7_lT6EcdQYXWP/view

    It is uploaded to itchio:

    papitomyking.itch.io/episode-7-minimal

  • I tried both the project file via Remote Preview and the itch.io link on an iPad Pro running iOS 14. In both cases the audio playback worked just fine.

  • I have similar experience. Can't play audio (music and sounds) at all on iphone. Xcode log says "Failed to load audio 'media/file name.mp4 : error fetching audio data:0"

    Xcode ver. 12.4, ios 12.1.

    When I uncheck Preload sounds option in Project properties, only error for music files show (not for sounds files) but still no music and no sounds.

    Some google search didn't help. Any suggestions Ashley?

    Everything works fine on Android...

  • .mp4 files are usually videos, not audio.

    You should make sure all your audio is in WebM Opus format (.webm), since it's the only format that is guaranteed to play on all platforms.

  • :-) tnx for fast response, my mistake, I thought .m4a files and didn't work with .m4a sound and .webm music files. Then I converted everything to .webm as you suggested and it works now without warnings.

    Just one more thing, every Xcode project shows lot of yellow warnings with possibility to update code automatically in some cases. Should we just ignore all these warnings since games work fine anyway?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)