Anyone else having issues with save files in google drive?

From the Asset Store
Template for a generic save / load system, fully documented in comments and video
  • So let me review the experience I've had with my save file trouble.

    [Session 1]So, a day or two ago I start a project and do a little work on it.

    [Session 2]I open my project to find it basically empty, all the stuff I did in Session 1 gone. I chalked it up to a lapse in my normally good saving habits and just started rebuilding all stuff that had vanished.

    [Session 3] Today, I open this file to find all the original stuff I did in Session 1, and ONLY that work. All the work I did in Session 2 is now gone.

    These are not separate files and after losing session 1 and thinking I had not saved, I was extra careful about saving. I paid attention to make sure I was logged in to my google account and that the corner message confirmed that the save was successful.

    Is anyone else experiencing oddities like this?

  • I'm not having that problem. Did you try restarting your computer and/or did you check and save it in the same file? Also, did you save it in session 1?

  • I'm not having that problem. Did you try restarting your computer and/or did you check and save it in the same file? Also, did you save it in session 1?

    I don't distinctly remember saving Session 1, but I generally have really good save habits. That said it had been a while since I worked in construct and it's possible I just didn't save that time.

    As for the possibility that i mixed up files: I checked everything in the Recent Files section of the launch screen. "Test-Colorwheel" is the name of the file I had started in Session 1 and worked on the whole time. There were two instances of "Test-Colorwheel" in the Recent Files section. When I clicked the older "Test-Colorwheel" file, it said "This file no longer exists" and removed it from the Recent Files list. At no point did I make a copy, so either construct or google drive did something to split these files.

  • it also needs to be saved with the same google account.

  • I don't think I accidentally logged in to a different account, but I checked the drive folders of my other accounts. If I did ever click on one of my side accounts, it didn't successfully create any save files. I know with certainty that at least in Sessions 2, I DID save and made sure I saw a "save successful" type message.

    I'm resuming work on the project I had and I'm making sure to save copies directly to my computer. [Session 4 lol.] If the google copy of the file survives a few sessions I'll just assume it's just any of these issues we've gone over caused a snarl. If the pattern continues and I lose Session 4 (at least on the google file) I'll report back

  • Yes, maybe it can also be a bug happening there. But for me i havent had any issues with google drive saving except that i forgot the password to my google account. so im recreating ;-; . But, ill like to say that we should wait properly for google to save it to 100 percent and wait for the notification(successfully saved) and we shouldnt go here and there leaving the project during saving time. but i hate to wait the notification. im thinking that it maybe a bug or you may not have waited till complete save .

  • I've had something similar happen to me with Google Drive. Sometimes, when doing 'save as' the default save directory will revert to the Google Drive base directory, rather than the current directory that the project was saved in. I didn't notice straight away and pressed saved, only to struggle to find it when going to open it later (on a different PC, so recent projects was no help).

    Happens occasionally, and now I remember to check which folder is being saved to when creating a new iteration of my project. *Maybe* this could be what you're seeing?

  • Is someone looking into this issue? as its so bad the state for Saving at the moment, I couldn't work yesterday it was all mess:

    1-The save to a folder half of the time shows an error that it cannot save but you click again and it saves

    2-And the save on the cloud it's completely broken

    https://www.dropbox.com/s/yd9p1q1yy90feln/saving%20on%20cloud%20problems.mp4?dl=0

  • I had this problem too when i tried to save to Google Drive. C3 would get to 100% saving then say 'Unsepcified error' or something similar.

    But it only lasted an hour or so, eventually it allowed me to save.

    I wondered if it was more a problem with Google than with C3, as I heard on the news Google services have been having global outages?

  • I'm still Having Cloud saves problems, it doesn't show any options available, is just black Window.

    Its been a long time now, is this permanent or someone is working on it?

  • usually this has to do with Google Restrictions. it's happened to me a number of times. One time it was for an educational institution, they changed some Google Security that caused this. And another time, something Google did forced me to set some 'restriction' rule that I had to undo.

    I started using Dropbox because it doesn't have these issues and its faster since it doesn't keep asking you to log back in.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • usually this has to do with Google Restrictions. it's happened to me a number of times. One time it was for an educational institution, they changed some Google Security that caused this. And another time, something Google did forced me to set some 'restriction' rule that I had to undo.

    I started using Dropbox because it doesn't have these issues and its faster since it doesn't keep asking you to log back in.

    Thanks Jobel

    I use mostly DropBox but there are none available as you can see on the picture its been now nearly two months like this with no options to save on the cloud.

    Something has changed on this last two month that broke everything, also the preview some times it gives black screens swell and it never happened before.

    If I werent still developing on Construct2 this would have affected me quite a lot.

  • tarek2

    I assume you looked in Settings and selected DropBox under 'Backup location'/'Default save location'?

    other than that you should be able to save to the browser or download a copy, which isn't ideal, but it does work.

    EDIT: I was also getting that dark screen until I changed the location in Settings to DropBox (it was prev

    Drive).

  • jobel

    Hoh you where talking about the automaticly save I see, I never use the auto save as Im use to save manually in c2

    I was talking a bout the manual save, when I try to save on the cloud it dosnt give any options

    Probably on video looks better: https://www.dropbox.com/s/2na815agcd8qxap/cloud%20save%20bug-1.m4v?dl=0

    other than that you should be able to save to the browser or download a copy, which isn't ideal, but it does work.

    Indeed thats the thing I been doing till now, some times is not ideal as small demos I like to save them on dropbox to load them in other PCs but is ok for now, Im just curious if its some one working on this as I dont hear anything from scirra.

    Thanks for the Tips though

  • jobel it looks like there was a problem with the Chrome 84

    I updated from Chrome 84.0.4147.135

    To Chrome 85.0.4183.83

    And now all the cloud options are working again))

    I recommend anyone having problems with cloud save to update Chrome may that could fix your issues.

    Video: https://www.dropbox.com/s/eo7e51sse3hbtry/chrome%20updated.mp4?dl=0

    Thanks

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)