Alpha gradient TiledBackground looking bad in Construct 3

  • Hi all! :)

    I have a PNG image, which consists in a gradient of transparency: the bottom of the image is fully opaque, and transparency increases towards the top of the image, which is fully transparent.

    When I import it into Construct 3, I see it different than the original image, like if it has been compressed. See the attached image for a comparison between the original image (top) and the same image imported in Construct (bottom), both with a black background, to view the gradient better.

    Any ideas? Maybe there is a setting for images compression that I need to change? Thank you in advance for your help! :)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi all! :)

    I have a PNG image, which consists in a gradient of transparency: the bottom of the image is fully opaque, and transparency increases towards the top of the image, which is fully transparent.

    When I import it into Construct 3, I see it different than the original image, like if it has been compressed. See the attached image for a comparison between the original image (top) and the same image imported in Construct (bottom), both with a black background, to view the gradient better.

    Any ideas? Maybe there is a setting for images compression that I need to change? Thank you in advance for your help! :)

    Yea have noticed this as well on the background in my game. Its not just on tiled backgrounds it appears on any blended/transparent gradient sprites also.

  • If images aren't importing correctly please file a bug following all the guidelines.

  • K1kk0z90

    In the meantime you can use Drawing Canvas to create your own gradients at runtime. It has the added benefit of lowering the download requirement for players playing your game :)

  • Ashley Ok, I'll file a bug report. Thanks! :)

    Thank you very much for your tip! I've just done a quick test and it seems to work well! :D

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)