Adding Leaderboard

  • Hello! I am trying to test the Leaderboard in preview mode for Google Play, but it seems to not work. The Sign In works properly and I manage to choose my account. When the game finishes I choose the score to be sent to the leaderboard I have in my game on Google Play account. However, when I press a button in my game which should Request Public all-time high-scores from the same leaderboard, nothing happens. Can someone tell me how to fix this? Thank you!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Can someone tell me how to fix this?

    No, not without any information.

    This is a issue with your Google setup, and I believe it is easier for you to get help on a google forum. The events in Construct is not that hard.

    If you want help, try to provide a full description of your events and the setup for your app in google console, and your game in Google Play.

    Then possible someone can help out.

    Also post stuff like this in the How do i section.

  • > Can someone tell me how to fix this?

    >

    No, not without any information.

    This is a issue with your Google setup, and I believe it is easier for you to get help on a google forum. The events in Construct is not that hard.

    If you want help, try to provide a full description of your events and the setup for your app in google console, and your game in Google Play.

    Then possible someone can help out.

    Also post stuff like this in the How do i section.

    Hey sorry for this. So I managed to make the Sign In automatically when I open the game. At the end of the game I do "submit score to leaderboard" and then I have a button which, on tapped, should "request public all-time hi-scores from ...". It seems that the submit part fails (I tested this in preview). I uploaded my game on Google Play Console, linked it to Android and Web app and I used in Construct 3 the Client ID from the Web app. As URLs I have https://preview.construct.net https://preview.construct.net/local and http://localhost. The app is signed and it can be well downloaded from Google Play. I guess I am still missing something from the Google Console setup. Any help would be greatly appreciated.

  • I am not sure the functionality works for local preview, even if linked to web app.

    try to just link to android app. and test it within the real app.

    just to be sure, you have created a leaderbord correctly and linked it? with a correct numerical format

  • I am not sure the functionality works for local preview, even if linked to web app.

    try to just link to android app. and test it within the real app.

    just to be sure, you have created a leaderbord correctly and linked it? with a correct numerical format

    Do you mean to use the App Id from the link with the Android app, not the one from Web App? I was actually confused by this, as in the manual they say to use Web app, but it seems more logical to link it to the android app directly... I will try it. I think I created it correctly. I followed a youtube tutorial, and seems quite straight forward, so I hope I did it right.

  • I might be wrong on this, but I do not think they have any updated manual for their new GooglePlay Plugin. (Their old plugin was web based, and I think their manual still relates to the old deprecated plugin. The new plugin is native android)

  • I might be wrong on this, but I do not think they have any updated manual for their new GooglePlay Plugin. (Their old plugin was web based, and I think their manual still relates to the old deprecated plugin. The new plugin is native android)

    Oh this makes sense. So technically I should not have to connect to web at all. Yet, it should still work in preview mode when using the Web link (it is easier to test)...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)