How to Access Right Click Menu on iOS/iPadOS Beta

  • I’m having trouble editing my Construct3 projects on my iPad Pro, in particular, accessing the right click context menu. I’ve tried long pressing and two finger pressing.

    I’m using the latest iPadOS Beta with a bluetooth mouse connected. I’ve attempted right clicking with the mouse without success, after setting up the second button to a tap or long press.

    Is context menu available for Construct3 on ios safari? If not are there alternative ways to access this menu I may have missed?

    Thanks!

  • I know this topic is a bit old but I wanted to mention I have this exact same issue as well. I also have this problem with and without a Bluetooth mouse. long pressing within safari on ios just doesn't seem to work at all on my iPad pro. Just doesn't bring up any context menu at all.

    Except the odd thing about this is when I run construct 3 in chrome on my iPad, it allows me to long press with my finger and my mouse and bam! I get the context menu. I'm not sure what chrome is doing differently but I'd much prefer using construct within safari because you can't full screen chrome on the iPad to my knowledge.

  • You can refer to this manual article : construct.net/en/make-games/manuals/construct-3/getting-started/on-mobile to learn about Construct's intended control scheme on mobile.

    Where the manual says to right-click, or open a context menu, tap and hold on the item. After a moment a menu will appear.

    If this does not work as intended, please post it to the GitHub issue tracker here:

    https://github.com/Scirra/Construct-3-bugs/issues

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I just want to leave this here for anyone with the same issue. I will be submitting a bug report soon as well.

    So I figured out a work around, it seems to be due to the recent move from ios to iPad OS.

    The recent move to iPad OS causes the safari browser to request desktop websites, disabling this in settings brings back the context menu, it also restores multi touch in projects from being unresponsive.

    So its not really construct that's the issue but rather Safari.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)