Airscape: The Fall of Gravity - OUT NOW!

  • I played all the stages and for me the only time Airscape stutters is when 1) collide with lasers and 2) collide with mines.

    Otherwise it was smooth as silk.

  • EDIT: Well, if silverforce's assessment is correct, it must be a collision issue. Any way of taking your mine/laser collision code out from the main game, to see if you can reproduce the lagging in a simpler context that you could share?

    /EDIT

    2 secs...that is quite bad. The only times I've seen halting that bad is when I've tried to do something crazy like spawn 1000 objects in a single tick.

    Some possibilities:

    1. Are you using the Line-Of-Sight behavior on any of your enemies? Silverforce's comment made me think of this, as I tried to use LOS for lasers once. LOS can really grind a game to a halt if it's used incorrectly.

    2. Save states, as per Aurel's suggestion, can cause a pretty bad halt if you try to use them during gameplay.

    3. You say your demo was exported before the new troubles with node. How far back? I seem to remember than there were janking/halting issues with some previous versions of node as well. 10.5 really seems to be the sweet spot.

    Seems like something is definitely amiss here. Hope you can figure it out!

  • Me on the other hand, outside inconsistent framerate in the intro, had no other performance issues.

  • Me on the other hand, outside inconsistent framerate in the intro, had no other performance issues.

    I got worse stutter in the intro, particularly when the drill came down and spawn that laser. It was around 1s delay everytime collided with that laser.

    In-game on the levels, the stutter was about 0.5 second only, faster. It was playable but definitely not something you want in a final release.

  • TiAm Just to confirm, those stutters don't go away with a lower resolution? Also, what resolution are you playing on when it's smooth?

  • I still get it at lower resolution like 1280 x 720 or even 640 resolution.

    I also notice a very small stutter (probably just a few frames) randomly, alongside the 0.5s stutter on collisions.

    There's no difference at 1080p (auto) to low res, the slight stutter is random, but otherwise smooth.

  • That's very interesting! I'll definitely have a look at that. Does it happen every death, or just on collisions with certain objects?

  • I re-played all the stages again, it seems to happen with some lasers and not others so I dont know if you handle them differently. 100% all the time with the laser in the intro scene after the drill pops out and fires that laser beam, 1s delay when collide. Other random lasers on stages ~0.5s delay.

    Minor random stutter is fine TBH, its not game breaking for me and if I didn't know better, I would have thought it was dynamic asset loading, which from a gamer's PoV, is acceptable. It doesn't occur often enough to impact the smooth & responsive gameplay. You did a great job with the platform movement & jump feel.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • First, just a few random notes:

      1. The map controls are only partially mapped to WASD. W and S move the selector up and down, but A and D don't do anything. Arrow keys work fine. 2. When you first arrive at the map, if the selector is over a level, you are neither told what the level is, nor can you select it, until you move the selector off it and back over it again. 3. This may just be me, but I would default to a slightly slower screen rotation rate. Brilliant idea to make this an option BTW. 4. The startup screen that says 'press any key to continue' doesn't actually take any key, only certain ones. 5. At one point during a level, I made an infinite jump. In other words, I jumped, and the jump kept going up forever. I finally figured out what was causing it: If you pause with escape, then press 1, it exits the pause menu and botches your movement in an odd way. This can lead to rocketing into the netherworld, floating above the ground, or drifting out away from the ground at odd angles.

    My experience with janking/halting:

    My system is a i5 3570k, HD4000 (no dedicated gpu), 16gb ram, Win 7 x64, SSD boot drive.

    When I first tried Airscape out last night, it ran perfectly. I ran at default settings, in windowed mode. I didn't see any halting or janking in the opening or during gameplay. Out of necessity, I initiated many unfortunate encounters with lasers, but to no avail. Had lots of fun, got a little seasick.

    Today...my luck hasn't been so good.

    I started on level 01-02. The game was halting terribly, not when kamikazing lasers, but just when I was running around. This seemed to last too long to be mere javascript compilation. Nor did changing resolution or fullscreen/windowed status seem to change things. But then...it cleared up.

    Exited back to the main map. Decided to try the first level again. You know how the first level opens with sqiddster falling a long ways, and crashing into the ground? Well, for me, that intro played like a malfunctioning slide show. The delay between frames was well over 2 seconds. When sqiddster finally hit the ground, the game stuttered a bit more and cleared up. Ran around a bit, everything seemed fine. Exited, re-entered level. Falling intro was smooth as butter.

    Shut the game down, rebooted it. Everything worked fine. No slideshow on level 01-01, no jerking, nothing.

    Tried again. One short (0.1 sec?) lag on the falling intro to 01-01. The occasional micro-halt during gameplay. Everything else ran fine.

  • TiAm whoa... that's insane.

    All this news is actually sorta good (well, I think, anyway). The fact that it ran fine on a HD4000 is great to hear.

    Now we need to work out what's causing the halting. I've never heard of inconsistent halting like you're saying, but I haven't really tested for it before either.

    Weird how everyone has their own issues with it :S

  • megatronx Has anyone else experienced the janking that TiAm has experienced? i.e. restarting the game fixes it?

  • Still the same for me. It's playable and I can get over the slight stutters since most of the game is smooth.

    I imagine its extremely annoying for you guys to troubleshoot since it seems to vary based on hardware heh.

  • It's odd, because I simply haven't seen a repeat of the 'mega-jank' behavior. I can get some pretty bad stuttering if I crank the rez all the way up to 1920x1080, but that's my iGPU, not the game. In fact, it stays playable, which is quite impressive if you think about it.

    I'm really caught in the middle w/ systems to test it on: I have an android phone(useless), an ancient Asus EEE(useless), and a really powerful desktop that is way more powerful than a run of the mill PC. Don't really have an 'average' system to test on since my last two laptops went to the blue screen in the sky...

  • I didn't experience any junk. Only bad performance in the intro. Remember I'm using NW that came with latest stable.

    BTW. Sound in Heartstone is not working for me too now! So I'm guessing something happened on my pc, thought chrome still plays sound.

  • Well it's good to hear that the sound issue isn't Airscape's fault... guess that's one problem down, haha

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)