How do I zoom without using layer scale?

0 favourites
  • 5 posts
From the Asset Store
All popular touch mechanics - scrolling, zooming, swiping
  • I am currently using layer scale to zoom in on my levels, but there is a screen flash/blink when the layer starts when the scaling is set below 1.

    This capx demonstrates the problem.

    Is there another way to zoom in on a static level without using layer scale?

  • matthew de

    I haven't looked at your capx, but I use layout scale and it works really well - I haven't seen any flashing/blinking - and I use it a lot.

    Set the "Scale Rate" of any layer you don't want to zoom to zero.

    the only issue I have ever had was with text objects - they don't zoom well because of the overhead in rendering.

    If I need to zoom, I use sprite fonts.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I currently have the UI layer's "scale rate" set to 0.

    If I change the layout scale in the event sheet to a number below 1 that layout with flash on start. If I change that layout scale number higher that 1 the flash will not be there on layout start.

    In the capx you should see levels 2 and 4 flash when you cycle back and forth between all levels.

  • matthew de

    ok, I definitely see what you are talking about... it looks (to me) like it is adjusting the global layer - stretching it out to compensate for the shrunken layers, and there is a split second when there is nothing to display around the edges of the background sprite.

    so, I tried over-sizing the background sprite way beyond the edges of the HUD layout and that seemed to help a little (not completely but was noticeably better). then I tried making new background layers on all the layouts (kind of defeats the purpose of a global layer). But that didn't really help. I also tried putting a wait 0 before you change the scale at start of layout to make that the last thing it does on the current tick - hoping that the global layer would get in place first. But that still didn't solve the problem and then you could see things snapping to their new size.

    so, I don't think there is anything else you can do. Over-sizing the background image gave the best result. You might want to file a bug report to have Ashley see if there is anything he can do about it.

  • Thank you for taking the time to look at it.

    I have already posted a bug report last week but no one has responded to it there. You are the first person to give me feedback on this issue.

    Could you please copy your findings on the bug report page?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)