how to make windows 10 package.appxmanifest work

  • From the bug report guidelines:

    [quote:3n3a6ya7]You closed my report without investigating it. I'm offended!

    Please do not be offended; we deal with large numbers of bug reports and our aim is to deal with them as efficiently as possible. We want to make sure you get in to the habit of filing useful, detailed, actionable bug reports which we can diagnose and fix quickly. This benefits you as well, since you are more likely to get your bug fixed, and sooner. So it is in everyone's interest that you learn to follow the guidelines to the fullest extent possible for every bug report. We may unceremoniously say that it is closed without investigation, but that is probably one out of 10 or 20 that day, and we want to highlight how you need to help us help you.

    If your report is closed, it should be easy to copy-paste it in to a new report and make the necessary alterations.

    While we of course appreciate paying customers, unfortunately a bug report without the necessary information does not suddenly become useful just because you've purchased the product. I must emphasise we have been doing this for years and the guidelines are carefully written to help us help you.

  • JLH1964 did you find a way around this, by any chance?

  • JLH1964 did you find a way around this, by any chance?

    No, sorry.

    I'd have thought it would be easier for the Construct devs to whip together a simple 'Hello World' program and run it through the tutorial steps - it doesn't work and hasn't for months for Windows apps.

    I will play around this weekend if I have time and see what I can find.

    I understand that Ashley is busy but we are paying customers and the software is not 'cheap'.

  • paula22

    > Ashley, I can understand that and I'm willing to collaborate, but it has a little bit too many rules and I can not understand why it needs to be closed and make people do it from scratch all over again instead of allowing editing it, feels very disrespectful and causes people to spend unnecessary time on it.

    >

    ... and yet you are more than happy to continue to flout the bug reporting guidelines, thus wasting Ashley's valuable time? Is your time more valuable than his?

    Dude, relax. He just asking a question after laying out considerable funds.

  • I'd have thought it would be easier for the Construct devs to whip together a simple 'Hello World' program and run it through the tutorial steps - it doesn't work and hasn't for months for Windows apps.

    I checked that Space Blaster exports and runs correctly as a Windows 10 app, so I know it works for at least that. This is why, as the bug report guidelines describe, it is essential to provide a .capx for us to be able to fix any problems. This situation is actually so common that the bug report guidelines describe what is happening in this very thread, and describes how you can avoid this situation by providing a .capx and following the other requirements such as detailing your hardware and software setup, and the exact steps you have followed.

  • Why isn't there a separate bug reporting page, where the user have to fill in and attach all necessary files to submit a bug report? Wouldn't that save you time closing bug report that aren't following the guidelines?

  • JLH1964

    "I will play around this weekend if I have time and see what I can find."

    If you find something please post it! I keep trying to find a way but I can't. I couldn't even make it work by opening my game with the older Construct2 and then in VS2013 for windows 8.1, seems that once the game is made in the new Construct2 it just wont work, possibly when made in a Windows 8.1 OS (is your OS also 8.1?)

    I know there's more people having this problem too, would be nice to know if there's anybody having this problem using OS windows 10?

  • JLH1964

    "I will play around this weekend if I have time and see what I can find."

    If you find something please post it! I keep trying to find a way but I can't. I couldn't even make it work by opening my game with the older Construct2 and then in VS2013 for windows 8.1, seems that once the game is made in the new Construct2 it just wont work, possibly when made in a Windows 8.1 OS (is your OS also 8.1?)

    I know there's more people having this problem too, would be nice to know if there's anybody having this problem using OS windows 10?

    Will do.

    I was on 8.1 when I got the error but since last week I'm on 10. I doubt the OS is the issue though.

    I know that about a year ago the C2 process to export for Windows would place all the artwork into an incorrect folder. Then, of course, the VS project would not compile. However, this is different as we can't even edit the manifest.

    I will create a simple project over the weekend and see what happens.

  • PS - Wonder if this is related:

    http://stackoverflow.com/questions/3172 ... tudio-2015

  • Sounds like it could be related yes maybe. I'm not so much of a coder though

  • I did a fresh install of Constuct and VS2015 and was then able to edit the manifest file but only in 'code view'. My hope was short-lived when trying to compile as I immediately got a build error.

    Same error as this guy who has been waiting for an answer for 3 weeks.

  • FYI:

    I managed to fix the non-access to the manifest file. After applying the following, the manifest opens as expected and is fully editable.

    Hope this helps. Probably should be added to the 'How to...' guide.

    Procedure

    ========

    In VS2015 Community, if you go to the following location as if creating a project, you will see a package listed and available for install. It was called 'Universal App Dev tools' or similar. Sorry, I should have taken a screen shot but rushed too much. If not installed, it will be the only option. I installed (long install) and manifest now works as expected.

    Update: ALL my apps are now compiling in Windows Universal - no more manifest or compile errors - time well spent.

    Hope this helps you too Paula.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You can also install the build files required by VS, by going to Control Panel/Uninstall a program, select MVSC 2015 and choose Change. Then use the VS window to enable the Windows 10 Universal Apps tools required.

    I also found you need to have an ID included in C2 properties.

    Issues that I still have are:

    Can't run app via VS in full screen.

    I wonder if this is still using Edge (which doesn't have full screen option) to run the app.

    Can't run Deployment Package

    When I build a deployment package for testing, and then install the app via App-AddDevPackage the install occurs without any issue, but there is no App launch icon to be found in the start menu.

    I will report back if I have any success in these areas.

    lol - I guess this is why MS don't build cars!

  • JLH1964:

    [quote:1rhh2j5o] Update: ALL my apps are now compiling in Windows Universal - no more manifest or compile errors - time well spent.

    Hope this helps you too Paula.

    I did this, and I still can't see the manifest , either opening with VS2015 or VS2013 (while installing, some 2013 files seemed to be installed as well). Then I also tried installing the Windows 8 tools (under the universal ones you explained how to install), and I still can't open the manifest. This continues happening even when I adapt my app to Construct2 r206, export for Windows 8.1 and open with VS 2013. But, when I try exactly the same with an old app that I had created from scratch in the older Construct 206, then it does work and I can open the manifest.

    So, as far as I can see, it is a problem caused by creating the game in the new Construct2 r212.2 in an OS Windows 8.1 (Windows 10 is not ready for my computer yet)

    Glad to hear it works for you anyway! And thank you for posting it

    michael:

    [quote:1rhh2j5o] I also found you need to have an ID included in C2 properties.

    I have the ID in my C2 properties

  • paula22,

    Are you using Windows 10? Windows 10 Universal Apps won't work on previous versions.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)