Why an animation of an object with Scale effect don't work?

0 favourites
  • 8 posts
From the Asset Store
This is a single chapter from the "Construct Starter Kit Collection". It is the Student Workbook for its Workshop.
  • Hi C2 fellas!

    An object with Move To behavior and Scale effect (made with "Set size" with "lerp" and "delta-time") have an animation that isn't working when I call him.

    When I call the animation of this object in an event, only the first frame is displayed with a short and slow scale effect.

    I tried to solve this in several ways, but I couldn't (perhaps because I already quite tired...).

    Someone has a solution for this?

    Thank you in advance the attention and collaboration of you.

  • Hi, the Move To behavior is ok, it doesn't interfere with the object animation, the scale effect on the other hand, does.

    I don't know how you are doing it, but if you are working with scale and animation at the same time, try to avoid change the scale every tick. Put the trigger once effect every time you change the scale, and try not to change it in the middle of the animation. If the object are not being scaled the animations should work properly.

    Give it a try and if you still have problems try post your .capx here so we can take a better look at what you're doing.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi RayKi! Thanks for your collaboration! ^^

    The object leaves from an one frame animation to a real "5 looped frames" animation long after the scale effect has been executed.

    I put the scale effect in a group, that is activated at the start of layout. Then the effect isn't under the condition "Every tick".

    Group Scale

    Object: Set Size


    lerp(Object.Height, 331,1.5*dt)

    Addendum: Even maintaining the object actual size with a boolean instance variable before the animation execution, the problem continues.

  • I also tried to deactivate the group of the Scale effect, but not worked.

  • Weird o-o

    Try uploading your .capx then.

    Sorry for not being able to help any further

  • Thank you for your attention and help, ^^

    I forgot to say that I'm using the R208 beta version of Construct 2.

    Is this the cause? o.O

  • I tried other things and... nothing.

  • I partially solved the problem by switching the SET SIZE by SET SCALE, for manipulating an object with one or more animations apparently only work well if it is through the Scale function.

    Now the problem is when I try to change the animation of the object before moving it to another position. The object gets with strange behavior, locking in a frame of previous animation while trying to make the transition to the next animation.

    So bizarre...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)