wheels tottering

  • Please, can somebody fix this little bug.

    Look at the wheels, when car moving, wheels tottering.

    I can't figure out point of joint axis.

    Here capx

    dropbox dot com/s/r05uesw7oambj9h/car.capx

  • .capx

    I have run into this problems as well.

    You issue is that the wheels and the car body must be exactly aligned on the layout.

    The wheels are not "moved" to the position they are joint at. They are joint at the distance at which they are set on the layout (try to move the wheels far way from the body and run the layout, then you will see what i mean).

    In your case the body and the wheels had some odd positioning. so take out a piece of paper and make sure that the wheels origin point in x,y coordinate is exactly the same as the point you make the joint at on the car body (in your case imagepoint 1(backwheel) and 2(frontwheel)).

    Hope i made myself understandable.

  • cvp i can't open your capx, programm says

    "The project was saved in release 148 or newer. Your current release

    is 146".

    But latest version at this moment is 148

  • i mean latest version at this moment is 146

  • i mean latest version at this moment is 146

    Its because i am running the beta version for my tizen project.

    You can find the 148 under beta downloads

  • cvp Thank you so much, you made it!!! <img src="smileys/smiley4.gif" border="0" align="middle" />

  • cvp one more problem appear, when car reaching end of road (right side of layout), joints breaking.

    Please tall me how to fix this problem <img src="smileys/smiley1.gif" border="0" align="middle" />

  • If you replace the "carbody is outside of layout" with "Frontwheel is outside of layout" that issue is resolved.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • LittleStain

    If i replace the "carbody is outside of layout" with "Frontwheel is outside of layout" it restart layout, i don't need it.

    i made invisible stop sprites, to stop car before layout.

    I appreciated your help anyway.

    Thank you! <img src="smileys/smiley1.gif" border="0" align="middle" />

  • You haven't made invisible stop sprites, you just have the body of the car bound to layout.

    Problem is your wheels aren't bound to layout so they react strangely.

    make your wheels bound to layout also and the car bounces back..

  • LittleStain

    Yes it's way smarter than invisible sprites

    Thanks

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)