What's Causing This?

0 favourites
  • 8 posts
  • For some reason (If you look at the bottom left of the Pic) I keep getting these unconnected lines. I'm not sure if they are the source of my errors but I want to know how to fix and prevent this or if it means nothing.

    When my game starts on the menu Layout and I click the button to go to the game Layout it plays fine, until I die (Health=0) got to intro screen Layout. But after the first time of it working correctly when I hit the start button again I either get some sort of JS error or when I click it does not go to the game Layout it does nothing.

    Could this be the issue, like some open loop or something not closed properly. After the initial start once I die and it goes back to the Intro Layout it does not seem like the game layout has stopped and reset completely. it's almost as if it's still running even though I've switched to a different layout.

    It's getting frustrating, I fixed it once but don't know how I made the error go away, but I added a few things to the game and here it is again.

    Thank you in advance for any help.

  • The line ends there since you are two levels in at event 52. Add a blank sub event to ZomDrops and you'll see the line end at event 53. It is just a graphical anomaly, and has nothing to do with logic. I have plenty of examples in my code, with no ill effect. Your issue will be something else. Do you have Groups enabled that start disabled usually. Groups do not reset their activate state on restart.

  • blackhornet Thanks at least that's a relief. I do have lots of Event sheets with groups, but yes, I will check each one again and let you know.

    Thank you so much

  • blackhornet I went through everything line by line and it's something to do with the on death and the start of the game.

    Uncaught RangeError: Maximum call stack size exceeded - Either I get a Pathfind.js Error or a Eveng.js error, and once but I somehow fixed I got a common(something).js.

    This only happens at the start of the game after the first run. On a new start everything goes fine, but when it starts the game again it happens.

    Thank you and anyone else who may know where to look in advance for your help.

  • Sounds like you are in an infinite loop calling Pathfinding. Check that code.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • blackhornet - First off thank you, I know you have better things to do so I appreciate your time and assistance.

    I checked that code like you said but I'm not sure what's out of order here.

    When I disable the Path finding it works perfectly, but of course as you can see the enemies now will not follow the path.

    What am I missing? I'm not sure if there are any other issues but this is definitely one of them.


  • Well, the "On failed" looks dangerous. If it failed the first time, it's going to keep failing, if nothing else changes. With nothing else to go on, I'd say kill that and put your "Every 0.1" back in.

  • Wow, I'm not sure how or why that fixed it, but Thank God it fixed it... Now I have to go back and fix all the stuff I messed up trying to figure it out

    Even in a working version of the game that's how I had it. Every tut I've seen on PF said to do it that way so wow, I'm taken back by this.

    I thank you with all my being, I do appreciate you taking the time because this was driving me nuts especially since it was working at first.

    That's what makes this place so great...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)