How do I use more than a tilemap at once

0 favourites
  • 5 posts
From the Asset Store
Change the size and position of everything without calculating anything!
  • Hey guys,

    I recently started using this engine (been very happy with it), but now i got the following problem:

    I create a tilebased game (like old nes zelda etc) and got plenty of free to use tiles from some resources.

    I am able to create a tilemap object and paint my map with it. However, if I create another tilemap object (with another tilemap .png) the first tilemap is no longer accessable for me (that means I dont see the "tileview" in which I can select the tile I want to draw) in the "tilemap-menu" (which appears after I create the first tilemap object next to my objects panel).

    I tried some stuff and the internet + a forum search didnt help me out, so my question is:

    Is it possible to switch between different tilemaps? If so, how? Am i just being stupid and dont see the right menu or whats the matter?

    I would be happy to recieve some help, thanks alot

    PS: I can create "new" tilemap-objects in which I load the old tilemap.png, but that looks like a graveyard after some work, because if I delete the old objects, my tiles are gone...

  • Have you placed each tilemap on it's own layer?

    The general way of doing things is to place associated objects on their own layer, such as background objects, main objects, hud etc, then you can hide/show Layers while you work on others.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi, thanks for your reply.

    I did this, both tilemap-objects are on different layers. The problem is I cant make the tilemapscreen (marked red in the attachment) to show the other set of tiles.

  • If you hide all Layers, click on the Tilemap Layer then Click on the Tilemap object in the Layout View, can you then access it?

    BTW what version of C2 are you using?

  • aaah I got it now. I always tried to click on the tilemap-objects in the objects view. It works that way.

    Thank you very much!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)