Testing a Crosswalk Install

  • Hi - I've recently tried to output a .APK file to test on an Android device using your "How to Export to Android with Crosswalk" guide.

    scirra.com/tutorials/809/how-to-export-to-android-with-crosswalk

    As a test, I tried to export one of your built-in example files ("Touch - zooming") in version r155. I did not change anything in the file.

    I export as "Android" to my Intel XDK project folder. I refresh my file library then build.

    The build seems to go fine. I download the .APK file from Intel (I have tried both x86 and ARM) and install to my device using the Android adb tool. My device is a Samsung Note 3 (4.3) running Google Chrome.

    I can see my new application. I run it and get a black screen (with a few random RBG patterns in the bottom section of the screen).

    Since then, I have also installed Genymotion and tried this on a number of virtual devices. I get the same result every time. Any advice? Am I missing a key step?

  • UPDATE: I also tried to test with the "Crosswalk Player" that you mention in your blog post:

    scirra.com/tutorials/809/how-to-export-to-android-with-crosswalk

    However, the link is broken and I can't seem to find this player on Google Play.

  • UPDATE: I can also "Preview on a Local Network" using my phone and it works fine (in Chrome and native Android Browser).

  • Hi, I still haven't gotten anywhere with this. Any ideas?

  • Does the Crosswalk built in emulator run the game OK?

    Have you tried emailing a link to yourself and installing it directly from Intel and not through the adb tool?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi, thanks for your help, Bertie. I could not find the "crosswalk built-in emulator." The Scirra documentation has a dead link to the "Crosswalk Player." Is that what you are referring to?

    Regarding email installation, I get the same result - Black screen. I have installed homemade java apps using the Android SDK before onto my phone and other virtual devices so I don't think the problem is with the Android SDK install.

  • UPDATE: I just tried an extremely basic Construct2 application (similar to "Panning" example) and I was able to run it using crosswalk. I still can't get "Touch - zooming" to work.

    As of now, I believe there might be an issue with the "Touch - Zooming" example which prevents it from running properly in Crosswalk.

  • Does anyone have a valid link for Crosswalk Player?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)