Stop the squishing!

  • Alright, so... This one has me completely puzzled.

    dl.dropbox.com/u/45478479/ClickBreak.capx

    For some reason, when the blocks spawn, and drop... They squish together. And, I can't seem to figure out why!

    Thanks in advance, also I really appreciate all the help!

  • I think this might just be the platform behavior bugging out because i don't think its really suited for this kind of thing.

    I'm not exactly sure what it is your trying to do, but maybe the physics behavior would work better?

    Here is your cap with physics instead: dl.dropbox.com/u/6660860/physics.capx

    I disabled rotation so they don't fall over.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • See, I was trying to do it without using the physics, because if you notice, it seems to leave little white lines. This is bad. :( I'd like them to be directly on top of each other. Is there any way to do that? I'd also be happy with the white lines going away. Either way.

  • You can get rid of the white lines by making the collision polygon a bit smaller.

  • See, I tried that. And it doesn't squish so bad with Physics... Thing is, I need there NOT to be physics. Because if there's enough of these objects falling. It's going to kill my game.

    What would also be nice in theory... Would be something like. They're all set in one spot, BUT if the block under it is gone, it will move down, and any ontop of it will also move down. So, kind of makeshift physics. You know?

  • Here's a way to do it using a detector sprite.

    http://dl.dropbox.com/u/5426011/c2/simpleboxdrop.capx

    In contrast Construct Classic makes this is easy to do with one event and no detector sprite.

    + System: For each Block ordered by Block.Y Descending

    + Block: [negated] Block: overlaps "Solid" : offset (0,1)

    -> Block: Set Y to Block.Y+1

    Hopefully those features will make their way into C2.

  • Oh man! What you did there is PERFECT. PERFECT. Thanks a bunch.

  • Okay! Found a flaw. Hah. After playing with it for a bit. It seems like if I make enough of them. The game reaaaally slows down. There a way to turn off the detector until it needs to be active again? Because that -is- what is slowing down the game. So many detectors running.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)