How do I stop black screen after splash screen Intel XDK

  • Almost everything is finished for my android port of GATE, literally just need to fix an issue where the splash screen pops up then disappears before the game launches. I've got the splash screen plugin checked in the Intel XDK just not sure where to go from there.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Anybody dealt with this one before?

  • Sorry, you've misunderstood the question. It's regarding the splash screen when exported to crosswalk android in the Intel XDK. The same problem occurs when I built it for iOS but as you can see that one was much easier to fix. Or at least the code made more sense: https://itunes.apple.com/gb/app/gate/id960357237?mt=8

  • Still struggling with this issue. Anybody able to help?

  • come one, somebody has to have released a tidy android app haha

    Driving myself a little crazy trying to figure this out.

    This is roughly what I've tried so far. Every test has brought up the same issue on android. Black screen > splash screen > black screen > game. I'm looking for splash screen > game. Or at least Black screen > splash screen > game. Managed it on iOS really easy, just no luck in the intel XDK > android crosswalk.

    1. Added splash screens to the project in www>Splash Screens and named them after their sizes

    2. in intel > project settings I added the splash screens,

    3. Added the SplashScreen plugin in settings (standard cordova plugins)

    4. Adding "<preference name="SplashScreen" value="foo" />

    <preference name="SplashScreenDelay" value="10000" />

    <preference name="SplashMaintainAspectRatio" value="true|false" />" to the bottom of config .xml

    5. added "<preference name="AutoHideSplashScreen" value="false" /> to config"

    6. added "document.addEventListener("deviceready", onDeviceReady, false);

    function onDeviceReady() {

    setTimeout(function() {

    navigator.splashscreen.hide();

    }, 2000);

    }" to index.html.

    7. changing the previous code to "document.addEventListener("deviceready", onDeviceReady, false);

    function onDeviceReady() {

    setTimeout(function() {

    navigator.splashscreen.show();

    }, 0);

    }" This actually made it work properly in the emulator but not on the phone.

  • i have the same problem have you fixed yet ?

  • psycorn I'm afraid I never did. However I did find a workaround by making the splash screen black. Then if you want an extra level of polish, fade your first layout from black

  • i found my problem was the cramberry chartboost plugin i'm working in a way to fix it but in the mean time i deleted the plugin

  • error because you use the plugin "touch"

    You replace "touch" with "mouse"

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)