How to make sprites appear sharper?

  • Is there a way to keep my sprites looking sharp in Construct 2? My sprites look very sharp and crisp when I design them in MS Paint but as soon as I load them into my game, they look very fuzzy and then when I play the game, they look even fuzzier.

    My main character sprite is 30x29, PNG and my whole screen size for the game is 256x224. I'm using Chrome.

    I tried creating a sprite that is an integer multiple of my desired size and then scaled him down but it didn't help much if at all. Any other tricks I can try?

    Thanks!

  • Try changing "Sampling" in "Project Properties -> Configuration settings" to "Point" instead of "Linear".

  • I went to the "View" drop down menu and it gives me several bars to choose from and the "Configurations Bar" is unchecked because I have the free version. I assume this is where I would need to go though? Are you reasonably sure that this will make the sprites retain their "sharpness"? Thanks for your help.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Not the configurations bar. Click on your project in the "Projects" window to the right, then change "Sampling" to the left under "Configuration Settings". And yes, if you're doing pixel art, I'm guessing it will solve your problem.

  • Keep in mind that this will only work with webGL. Your other alternative is to design the character at native or higher resoution.

  • Thank you very much Nimtrix! It worked!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)