Sound Not Playing if I build APK

  • when I build APK then Sound not playing in Mobile but while previewing from Intel XDK to my mobile then its working fine. I don't know what I am doing wrong. I have attached this file. Pls take a look into this

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • luckyrawatlucky

    Please don't delete and recreate your post just to create a bump.

    You are allowed to bump your own posts after 24 hours if no response has been forthcoming.

  • Bump

  • Bump 2

  • Same issue here. This is a serius problem for me because my app is all about sounds.

  • Bump again

  • I have noticed that when I install the apk the first time there is not sound. I have to close the app and reopen, them the sound works normally.

    I have tried this in a mobile and in a tablet. In both of them happen the same.

    Maybe this was the reason for to many uninstalls per day, so I wrote a note in the main screen asking the user to reopen the app.

  • If you upload a apk example, I might try it on my mobile.

  • https://play.google.com/store/apps/deta ... pbeatmaker

    I have noticed this after the xdk updated. I don´t know if this happen before as well. If you can install it and tell me if you have sound at first time would be nice.

  • If it worked the first time but the sound seems it not well synchronized with the sequencer.

    --------------

    Veo que eres de España, yo también.

    A veces el sonido no queda bien sincronizado en el secuenciador, algunas veces suena como debe, otras suena sin sincronización, se retrasa un poco.

  • Ey, gracias por el feedback. Si, aqui un constructor gallego.

    Cuando pones un sonido tarda un segundo en sincronizarse. No se como solucionar eso, me imagino que sera debido a la cantidad de colisiones que tiene que checkear por cada botón en la pantalla. Quizas en un movil de última generación funcione mejor. En mi sansumg galaxy 4 mini me ocurre lo mismo.

    Espero que no se me heche el foro encima por hablar con eñes.

    Un saludo

  • I have galaxy s6 and happens to me has happened to me before, using "every 1 second" desynchronization occurs and does not sound every second, sometimes there is a delay, it passes on Android, windows that desynchronization does not occur.

    ------------------------

    Yo tengo galaxy s6 y sucede, a mi me ha pasado en ocasiones, al usar "every 1 second" se produce una desincronización y no suena cada segundo, a veces hay un retardo, pasa en android, en windows no ocurre esa desincronización.

  • at least your apk has sound working

    but in my apk doesn't sound play with many reopen

    I reopen many time but don't working

    pls check my caps

    or tell me

    Does I need any plugin related to sound to work sound?

  • hello, i have same problem with you but i solved it. Just reimport your sound in C2 using WAV format. Then C2 will encode into multiple format, just press convert and OK button. Now don't remove any sound files. Export it again and now it should be working.

    So, basicly you need to import WAV format in C2 and C2 will convert to the right format.

  • hello, i have same problem with you but i solved it. Just reimport your sound in C2 using WAV format. Then C2 will encode into multiple format, just press convert and OK button. Now don't remove any sound files. Export it again and now it should be working.

    So, basicly you need to import WAV format in C2 and C2 will convert to the right format.

    But that is the normal way to do ... what were you doing before ?.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)