Sometimes Pathfinding Works, Sometimes Not

  • Hello,

    I have objects have pathfinding, but sometimes they don't move, and after i close game and open it again, they start moving. (android)

    on path found -> move along path

    i also have this.

    I don't think we need capx, because IT IS SOMETIMES WORKING, AND SOMETIMES NOT WORKING. that means they can move sometimes, so there would be nothing in the events. i wonder if it is a bug or sth of pathfinding/c2/crosswalk. (also sometimes happens when testing in the browser)

    Anyone experienced this problem?

  • up

  • Sometimes could mean there are conflicting events sometimes..

    So providing a capx would be the best idea..

  • Have you tried to regenerate the obstacle map at the beginning of the layout? I had to do this to make it work some time back. Not exactly sure why.

  • oceldot this is a good idea. I have had a similar issue, will try that as well.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hello,

    I have objects have pathfinding, but sometimes they don't move, and after i close game and open it again, they start moving. (android)

    on path found -> move along path

    i also have this.

    I don't think we need capx, because IT IS SOMETIMES WORKING, AND SOMETIMES NOT WORKING. that means they can move sometimes, so there would be nothing in the events. i wonder if it is a bug or sth of pathfinding/c2/crosswalk. (also sometimes happens when testing in the browser)

    Anyone experienced this problem?

    Not saying it is, but your problem might be related to this one that I experienced. If there is something wrong with the path finding behaviour. Then it might explain why yours sometimes work and sometimes doesn't.

    https://www.scirra.com/forum/path-finding-why-doesnt-this-work_t117025

  • Thanks for all replies, nowadays it has started working - i did nothing. Just after exporting a few times. But after launching the game 5-6 times, it happens again, and relaunch the game, problem disappears :/

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)