[solved]Player Firing Only Working on 1 Layout

  • Ok so I am doing a space shooter, I have 1 level layout and then also using a demo layout for testing new elements and then I just transfer everything over to the main game mechanics event sheet once it is perfected. The player ship firing was working fine on level 1 but now is no longer firing. It still works on the demo layout, each are calling from the same game mechanics event sheet.

    The way it is setup is a level 1 event sheet with game mechanics event sheet included, the demo is a demo event sheet with game mechanics event sheet included. The ships settings are the same for the demo layout and the level 1 layout, tried deleting the ship instance on the level layout and putting back in, nothing, tried copying ship from demo layout and copying to level 1 and still won't fire on level 1 layout.

    Any idea's what might be causing this? there has been no change to the firing events, and even if there had why would it fire on the demo layout but not the level 1 layout? Have checked the level 1 event sheet to make sure there is no call to deactivate the player firing group and everything is fine there. What else should I be looking at?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It's hard to tell without seeing your capx.

    There may be something in your code, or maybe some object is missing on the level layout.

  • I figured it out, just something simple. For whatever reason some of my layers on the level 1 layout got deleted so I had to re create them, because they are the same as in the demo layer the code didn't get deleted as the layers still existed on the demo layout so was double checking all the spelling for the layers on layout level 1 and instead of PlayerLayer i had Player Layer, removed the space and problems solved.

    Is usually something simple but you get stuck in the it must be something big. I was looking over everything for a solid half hour before I posted, don't know why I didn't think to check that part

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)