[solved]changing layout does not work

0 favourites
  • 3 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • Hi!

    First, i want to apologize for my english. as a french user, i often make mistakes ^^ So, here comes the problem i'm currently facing:

    I have issues while trying to change layouts ingame.

    i'm using R195 64 bit on steam.

    i've tried to change layouts on a project (5 layouts), but no way to make it work, so tried to make another project, smaller, with only 2 layouts, and faced the same issue. so i don't know if i'm trying it correctly, or if it's a bug i should report.

    i'm using quite a simple mechanism (the same on the two projects):


    button on layout1

    button2 on layout 2


    sprite on layout 1

    sprite2 on layout 2

    when i click on button, i want to go to layout 2

    when i click to button2, i want to go to layout 1

    but nothing happens in preview or when i'm exporting project and saving it on my server. everything else is working well if i select one of the layouts and try it, or use it as the first layout when exported.

    the basic project capx file is attached

    please, can you help me guys? i'm searching for near of 3 hours now, have tryed on firefox and google chrome, have searched on google and scirra forums without finding answers that helps me


    //edit: i've tried to uninstall construct 2, but nothing changes after installing it back

  • Its not necessary to use the mouse function just use the Button on click feature and it works fine. Here is you capx fixed.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • oh gosh! i'm really sorry ! yup, it works very well like this! such a basic solution.... thank you very much !

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)