[Solved]...Get sound on iPad when testing

0 favourites
From the Asset Store
Best soundtracks for any game. High quality and engaging assets.
  • Ok this is all so crazy.. so on the one hand i see a simple oversight with the touch tests.. i wasn't triggering the play sound with touch, but i was with mouse click..

    fixing that, it works for that test.. but the actual project was wired up correctly. I can't figure out what my actual project is doing different! it plays audio fine on pc.. i could understand if may some sounds wouldn't fire off.. but none?   

    then to top it off.. i go to test another touch test with an audio file that imports without any errors.. its something that should play in my project automatically.. not something that is triggered by anything except on start of layout and to wait a few seconds

    part12studios.com/temp/Bloop20 this is the project and as you can see audio is fine.. warning on ipad i don't have touch controls in place so it won't interact.. but you should still hear the music and the voices even on the ipad version without anything special..

    so i made another test here is the capx


    part12studios.com/temp/touchtest6 (my website works consistent with Dropbox)

    see how "click" plays? but scene1a doesn't?   is there a file size limit or something? I just don't get it. I think it is ultimately something to do with the

    part12studios.com/temp/Bloop25 this one is the same but i replaced the two non-playing voices with SFX1 from your suggested free asset folder.. and yet they still nothing will play.. so its really strange..

    Also thanks so much for your help with this. This is my first serious project with C2 and it's been overall a great experience, but not to be so far and to have audio hamstring my project is unfortunate! I know there is a solution though.

    On a side note i recently bought a sinclair 1000 (with ram module) off of ebay.. it was my first computer way back when...

  • Browsing on an android tablet so I can't check now-but I will have a look tomorrow.

  • Ok - after a quick look, a read of the forum and some guessing.

    I downloaded your test 5 capx and "what do animals need" plays on ipad but no click - but you say the other way around ?

    I replaced click with a sound from the assets and it works.


    Looking at your click sound it is only 24kbps - I am sure I've read somewhere that c2 will only go down to 96kbps.

  • ok so I took your project and posted it.. part12studios.com/temp/touchtest7 so weird.. the cancel sound you used plays, by my iPad2 does not play the scene1a.wav

    I looked at the source file and it's clearly a 44,100hz 16 mono audio file so I don't see there being anything wrong with it that would cause it to not play. when i import I always select 128kbs.

    now looking at the source click file, its a 48,000 16bit stereo so there is some inconsistency there, but not something that would explain the voice audio.

    oh and get this.. so i also own an iPad Mini.. and guess what, the audio does work on touchtest7.. now it doesn't play audio on bloop still, but at least on a really basic level there is clearly some differences in hardware. they are both running iOS7

    As for the click sound 24kbs, where are you seeing that? Maybe I'm overlooking something else in terms of audio format.

  • oh and then of course now that i go back to touchtest7 on iPad mini to try again.. it doesn't work now.. and now part12studios.com/temp/touchtest6 works! wtf? this is insane.. I don't get how this could be so inconsistent and difficult to troubleshoot.

  • Hi everyone, I just wanted to return back to this. I believe the issue I was having with audio wasn't C2 at all. It was the MIME settings on my web host service. m4a were not enabled. So if you ever have trouble getting audio to come through. Be sure your provider is configured to stream ogg and m4a.

    This also helps with some Internet Explorer issues people may come across where they have no sound even on PC..

    So after having fixed this issue, I went back and redid some tests.. http://part12studios.com/temp/SoundTest2/ works great now for both iPads.. I did however have to use preloading to insure they worked because when i didn't preload, audio didn't seem to fire off even after waiting awhile and even refreshing.. so seems that preloading is your best friend to insure audio is loaded and ready to fire off.



  • I'm glad you got it sorted - but I did ask about the mime setting in my second post...

    Not got ipad available at the moment to test - there is something about music(?) not playing until a touch has been registered I read about but can't check at the moment ?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • yea i see that now. I wasn't familiar with MIME.. that it was something that required action on my part.

    yea that is true about the touch to hear sound, but that's usually addressed by having some kind of "touch to continue" prompt which feels natural to the user and achieves the need for touch.

    I was just testing on my Galaxy S4 and it seems like sound is terribly delayed, not sure why that is, but i can't imagine its anything C2 has control over.. its so slow it's almost like the preloading is occurring with each touch.. but that's for another day i guess..



Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)