[SOLVED] How do I disable collision checks globally?

  • I'm getting about 30k/sec collision checks and do not require these checks as the app is more trivia/educational.

    I went through piecemeal and disabled collisions on every applicable object and still see the same amount of checks on debug. Can these be stopped? Thanks, -Steve

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • the best way i can think is make an on start of layout event which has each object listed with enable collisions- disable

  • There shouldn't be made any collision checks unless you use On collision or Is overlapping another object... in your code as far as I know.

    But there is an action that lets you disable / enable collision

  • There are no "overlapping" events. But, you led me to the solution!

    **It's the "mouse is over" conditions causing those 30k checks.

    So, even with collisions disabled on all applicable objects, those mouse conditions alone give me 30k checks/sec. If I disable my "Hover" group, which contains all these "mouse is over" events, I get 0 checks.

    Thanks fellas. Also, I'll assume now that there is no global disable, but I was barking up the wrong tree there anyhow.

  • There are no "overlapping" events. But, you led me to the solution!

    **It's the "mouse is over" conditions causing those 30k checks.

    So, even with collisions disabled on all applicable objects, those mouse conditions alone give me 30k checks/sec. If I disable my "Hover" group, which contains all these "mouse is over" events, I get 0 checks.

    Thanks fellas. Also, I'll assume now that there is no global disable, but I was barking up the wrong tree there anyhow.

    Hi Stweve,

    did you find a simple solution to reduce the number of events, while still playing with the mouse cursor style and/or the images rollover status ?

    Thanks

    Mathieu

  • I went with group disable to manage this, but was splitting hairs without knowing it. This was all to improve performance on older devices (e.g. Note 4 or older iPads were very slow) but it was WebGL effects (tinting on spritefont objects) causing the slowdown as opposed to collisions.

  • Thanks for the hints, then. I won't lose my time with this !

  • My pleasure!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)