[SOLVED] Can't integrate advertisments, tried everything.

  • So I tried the admob plugin present in construct 2 to make an advert trigger (following the exact procedure given somewhere here) but it didnt showed any ads. I figured it was because it was made for Intel XDK ?

    Than I tried the cacoon ad with cacoon canvas plus which again, didnt showed the ad on trigger.

    Than I tried enhance and again, no luck.

    I am exporting my project as cordova and making it an apk through cacoon.io, I hope i'm not doing anything wrong in this process (still, the test ads wont show up even in the construct 2 testing).

    I am trying to integrate AdMob

  • Have you tried using Enhance to integrate ads?

    We support admob and a wide range of other networks.

    Check it out here : goo.gl/LUc3iD

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thank you for your consideration and yes, I tried that aswell.

    Regarless of such, somehow it all resolved itself.

    I used my ad ID with the built in ad plugin in construct 2 and exported it with cordova. Than I used Cocoon where I added the AdMob plugin for Android and than I compiled it to the apk.

    Initially the ads were not visible but for some reason after a few hours (after publishing it on the play store) the ad mechanism started working perfectly.

  • Glad to hear you got everything to work!

  • can i ask what cocoon admob plugin did u use cause for me when i use any admob plugin it dont compile and fails all time

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)